SVG files in Luban don't give me VECTOR option

I’m sure this is the wrong channel for these questions but it’s LUBAN who has shown me my mistakes and I’m wondering if anyone can help me.

I used Inkscape to convert a jpg into a SVG. I watched YouTube videos and I followed them to the T. When I import the newly created SVG file into Luban this is what I see in the EDIT screen:

  1. First question - It looks good except Luban doesn’t allow me to choose “Process Mode” options such as relief or vector or I give me the option to check the “invert” box.

  2. My second issue identifies itself when I go to process the svg files. This invisible rectangle shows up when I preview the job. This rectangle is coming from inkscape but I have NO IDEA where because my SVG files shows no such rectangle. It’s mind blowing and I have no idea how to get rid of it.

  1. Lastly, once the yankee logo processes in Luban it loses the “fill” aka all of the solid black dissappears and all I’m left with is the border of everything but there’s no etching to fill in the solid black. If I had the INVERT check box then I could just click invert and it would shade in all of the hollow areas but as state earlier that check box doesn’t appear.

So if anyone can help me with ANY of these issues that would be greatly appreciated. I’m exhausted trying to figure this out and at this point I am going through the definition of insanity do the same thing over an expecting different results. lol

Thanks for your help!


Share your SVG file here and I will try it at our end. Tell me the version of Snapmaker Luban as well.


After you trace the bitmap in Luban make sure that you delete the jpeg you started with.
Save as simple svg.

1.You need to select the graphic to be able to choose the options. Either click on it in the window or the object list.

  1. Image border on laser?

  2. There’s a check box for “fill” when you’re in the process tab.

Share both files so we can see what’s happening.

You might have better results with either of these:



1 Like

@Edwin Here’s the file. Thanks for your help!
Yankee hat and bat logo black and white

@sdj544 :rofl: I think I’ll stick with the Yankees and grind through this problem until it’s resolved. But thanks for your trying. lol

In terms of the extra image in the file, I actually did do that at first. Rookie mistake when converting jpg to SVG is not moving the SVG and deleting the jpg underneath. I went back and did that so I know there are not two images there. I even used the bevier curve tool again and cut it out a 2nd time and it still didn’t work, rectangle still shows up in preview tool path screen. I posted the file above in another comment if you care to take a gander. I appreciate the time you took to help.

The problem is the same as on the post I’ve shared.
Somehow you’ve got a bunch of extra/repeat layers and an extra box that is transparent which then shows up as the extra outer path.

Not sure how you’re doing your trace to bitmap that’s causing that. I’ve never been able to do it, but I’ve seen plenty of people do it. It might be that your white in what your tracing isn’t a 100% white and that’s causing it to be traced too.

If I open it in Affinity Designer (an Adobe Illustrator clone that’s actually reasonably priced) I can better see the layers and what they are.

You can see a bunch of extra layers and the mystery border is there.

Inkscape is great, but it’s user interface isn’t great and not great at handling layers. What it’s really good at is converting to vector and manipulating vector. The “erase existing paths” tool works better than anyone’s and is just like using an eraser in a regular photo/art program.

I exported your svg as a png and then did trace to bitmap myself in Inkscape with these settings (which is what I usually use):
Screen Shot 2021-05-13 at 10.46.39 AM
And end up with this:
Yankee hat and bat logo black and whiteINK
Which as you can see only has one layer:

So not sure what you’re doing in Inkscape to get the result your getting.


Wow. Thanks @sdj544 I’m really kinda blown right now because I checked the layers in Inkscape and didn’t see any besides the one I thought I had. Even right now opened the file in Inkscape and do not see all those layers. Do you have to check a special box or something to get them to show up? I appreciate your help and thanks for sharing the conversion settings. I’m going to practice on my own and see if I can duplicate your efforts.

Inkscape has a weird way of displaying layers. It has both ‘layers’ and ‘objects’ and not sure why each one is different and what the difference is. I could research and find out but I don’t really care since I have a workflow that works for me and why I use Designer.