J1 and the Simplify3d wifi connection

Hi gays,
Seeing the recent Simplify3d upgrade to version 5.1 I tried to connect the J1 via my wifi network to avoid creating the gcode and sending it to the J1 via Luban…but when Simplify3d did the search, both in automatic than in manual, it has not found and recognized my J1 (naturally the J1 on and with Luban works perfectly).
Has anyone already tried? are there perhaps ports to be opened on the firewall and/or on the roster? Thanks in advance

I have the same problem, I am curious how it is solved!

You can try this tool, which connects the printer from the command line and also supports S3D OctoPrint mode.


WOW, thank you very much, I will try it as soon as possible.

I also have the same problem, is there possibly a solution in the meantime?

Sorry macdilan, I thought it was an app or little .exe and I just have to run; i don’t understand what i have to do after download with the “sm2uploader”.
Can you explain me?

Please read this: sm2uploader/README.md at master · macdylan/sm2uploader · GitHub

It’s a command line tool, no GUI

This is an interesting possibility.
I cannot succeed discovering my J1 though;

Any thoughts? Thanks!

You could try to specify the IP of your printer and to add a timeout with the following options

-timeout 86400s -host

Change the line 29 from

%cmd% %host% -octoprint


%cmd% -octoprint -timeout 86400s -host

Has anyone gotten this tool to work with an A350? I can run the tool manually and upload gcode. When I try it in S3D, it finds the printing, but then gives this error:

Connection failed.

Attempting connection at ws://…

Connection refused. Make sure the device is turned on and the connection details are correct.

Anyone have an idea on how to address this?