Help Print from usb


#1

Hi - export .gcode files to memory stick not been recognized when plugged into snapmaker

It does seems that snapmaker recognized thememory stick as the Files menu is available on the screen - however it does not display any files.
I have tried different usb memory sticks with the same result


#2

Do the files have the “.gcode” extension?


#3

Yes the files have .gcode extension - I used the snapmaker 3d software to generate the gcode and then exported it to the memory stick


#4

Can you upload a photo from the Snapmaker3D screen just before exporting the file? maybe I can see if there is an error in size or shape …


#5

Ok 3 pictures

  1. screenshot of snapmaker3D
    2 screenshot of file on f drive
  2. pic of touchscreen



#6

@gjo Gill when you place your G-Code files on your SD make sure they are in the base or root (/) directory. If you place them in a subdirectory they will not be found when you attempt to access them for printing using the LCD Font Panel. Also make sure for 3D printing the file extension is gcode and for laser engraving or CNC carving the file extension is nc.


#7

@jokeefe I made sure that the files are in the root(/) directory and the extension is gcode. Interesting when i copy the file from the memory card to my linux PC and then delete it from the memory card (using the linux pc and copy it back from the linux PC to the memory card. The snapmaker found the file. So something strange with copying files from my windows pc to the memory card.


#8

@gjo Gill with some older versions of Windows the extensions will truncate to 3 characters unless you override the default. I tend to forget about this because I have reconfigured all of my systems to allow my Unix, Linux, and Windows systems to play nicely together based upon the lessons I have learn over the last 40 plus years of working with computer systems.


#9

@jokeefe I do not think that’s the issue as both linux and the PC shows the files extension as .gcode. I also checked the properties of the file in windows and in linux and could not see anything different between the files snapmaker recognized and those that it does not.


#10

I have been unable to print from USB at all have tried reformating to FAT, FAT32 and NTFS none have work have also put them on root directory the snapmaker has never found them yet. running the most current version of snapmaker printer firmware.


#11

it maybe a windows 7 issue - files copied , exported using a windows 10 system seems to be found by snapmaker


#12

Hi, I am having trouble finding the files on the snapmaker screen via my USB.
I think after researching for many hours this thread has pinpointed my problem. My file is being saved as ‘file’, this is for laser engraving. My 3d prints are saving as .gcode and work perfectly. Is there anyway of correcting this. I’ll post some screen shots of what options it is giving me and what it saves under. Any help is appreciated.




#13

Same problem here guys. Nothing shows up when I use the usb stick with gcode exported to it. The screen is black with no listings, but the home, back, previous and next buttons are still there. Any good solution for Win users without bringing linux in?


#14

Hi, as I had the same problem and could not find the answer quickly anywhere I tried to solve it myself and found this solution. Format your USB_stick with cluster size 8192. That did it for me and now all work fine and show my .gcode files.