Help 10 watt laser owners

Hi I would like to ask someone that has the 10 watt laser .
Could someone take a screenshot shot or two while using the camera capture and calibration function , I’d like to see what it looks like to see if I can narrow down where my problem is .
All the manuals and videos don’t show the computer screen shots .
So if anyone could take two or three shots I’d be very grateful or a short video would work too .
Many thanks in advance, this would help me out a ton .

Neil ………

1 Like

No Artisan owner here.
First you have to calibrate the camera and thickness measurement on the machine.
Then you should be able to calibrate the camera-capture on luban.

1 Like

Hi. Yeah , I’ve done all the calibrations, I’ve read all the manuals , watched videos but none show what you see on the laptop while it’s going on.
Someone mentioned about a red and black screens, one good one bad I assume but after the picture is taken and I move the little dots then nothing happens no matter what I do , so if someone could take a couple of screenshots at that stage it would help me figure if I’m doing the wrong thing or there’s a fault somewhere.
I’ve been trying this every which way for 3 or 4 weeks ago , it’s had more calibrations than it would have in it’s lifetime and button clicking well my mouse runs away screaming !.

But thanks
I do appreciate your help.

Ps I have an open ticket from the help people on this too from about 2 weeks back and they mentioned all the usual stuff .

I guess you have to make sure a good connection over wifi. (Additionally to say, the camera module communicates over bluetooth to the touchscreen)

Only a few seconds spinning circles then got the capture-pictures.

Thanks so much your screen shots have helped me highlight a problem with the Camera capture feature .
I followed your shots and took some of my own to show the problem I have .
Again with my wife who is very much smarter than her husband we tried it over and over to get it working.
The shots of the calibration page is where the process stops dead. Nothing I do can get me beyond this point .
The next shots are when I tried to locate the helicopter image on the paper and to make sure I also used aSM manual as a background as well , none of these options would actually run , the laser just kept going to the far top at the right hand side and would just stop there.
I will forward both your shots and mine to the SM help desk if that’s ok with you ?.

Well again I am very appreciative for your help and going out your way to do the camera capture calibration.
I;m assuming you live in Germany and the next time you are in Alberta Canada I owe you some not very good beer , or bottled from Europe which tends to be the best option.
Best Regards
and thanks

Honestly, the camera feature is mostly useless. You cannot use it with any accuracy. I think I calibrated and used it when I first got the 10W, but haven’t even done the setup in 2 years, let alone use the feature.

You’re better off to make a 0,0 jig to position your works materials.

Yes I believe you are right again .
I have managed without it and get very reasonable results .
I ,m fairly comfortable using the X,Y,Z axis , I used to do some mechanical machining in a prior lifetime but it’s amazing how quickly it returns.
I sent those shots off to SM just to see if they can come up with a fix and like you say if it doesn’t work out oh well.
Many thanks I do appreciate your advice , help and time .

Regards ,


If I travel to Alberta I will take some Austrian beer with me for you :wink:

I guess you didn’t do the initial camera calibration on the touchscreen.
In this calibration the laser cuts 4 lines in a square. After this you could do the calibration and alignment in Luban.

Maybe this hint helps you further at calibration:

Hi again .,
Sorry for assuming the wrong country , I ,m originally from Scotland and I went camping and touring a lot in Europe, one year to Austria :austria: .
You live in a very beautiful part of the world my friend and nice environment for a Snapmaker machine , I must say Alberta is also a very nice place to have a Snapmaker , not unlike your country in scenic ways very picturesque , but most of the beer is Imported stuff from the USA , there are some good local ones here and there .

I had done the step prior to the camera capture where the piece of paper gets neatly cut into a square , which could be a useful tool one day??!! especially if all our scissors breakdown!.

Well thanks again for all your help my friend , I may well ask you again as I’m only had my machine for 10 or so weeks but for the most part I’m learning as I go and reading this forum has upped my knowledge too .


Regards ,


You are welcome :wink:.
Cheers!! :beers:

I had this issue also. I put something on the bed that I could clearly see all edges then went thru the process again. Moved the 4 dots around until the preview side looked like a normal straight down photo. That fixed my issue. I will try to take some photos tomorrow for you or I’ll make a YouTube video of the process and give you the link

Hi sorry for not responding to your offer of help which I appreciate very much .
My main issue at the moment is that after I adjust the dots nothing happens I click on calibrate and the other button which I’ve temporarily forgot.
So I don’t get any further than that page with the alignment of the dots , I’ve been told that it then splits into a green and red screen and no matter how many times I click and align the dots nothing changes.
I’ve been ‘’trying’’ to get help from the tech support but so far , I’m feeling as if they think I’m a dimwit that can’t read the manual or trouble shoot .
I sent them a bunch of screenshots of the camera capture on my laptop but now they want a video of it as well, I feel like they are just hoping I’ll get fed up and stop but as you know these machines are expensive and the features should all work out of the box .
So thanks for your offer of help , I think for now I need to keep going with the support department.

Regards ,


Strange that even the 10w manual doesn’t show the split screen either, but I certainly see it on my machine.
Firmware update of the tool head?

I doubt firmware version has anything to do with it. It’s probably just old an manual and new version of Luban. I have new tool head firmware and old version of Luban, and I don’t get the split screen.

If this is the split screen we’re talking about, it existed with the 1.6W laser, and this was before the 10W manual would have been published.
The 10W manual that doesn’t show this screen may be old but it’s the latest available to download. Maybe the difference is something to do with Artisan vs SM2.0

Thanks for replying to my note , I sure appreciate your knowledge , the screen shot you have there is as far as I get , I can move the dots but after that neither options work it just sits there .I have tried everything I can think of but nothing gets me past that section, so it takes a really bad picture and then I align the dots then nothing , so I can’t use it or calibrate it .I’ve even tried to do the capture as it is but it won’t let me continue.
Again I sure appreciate your help. I’ll see what the help people say from SM.

Regards ,


Hi thanks for jumping in with help on this , I gladly accept all the help I can get .
I’m really at a loss right now, I’ve put it into the SM help people because I can’t progress past the alignment of the dots to calibrate the bad photo it takes , it just refuses to calibrate I shift the dots to where I think and hit the calibrate button’s and nothing happens after that .
I really don’t know what is going on but it’s an option that I can’t use for now .
Thanks again

Regards ,


Did you the calibration of the camera of the laser in the settings of the touchscreen?

It shows you to lay a paper on the bed and the laser cuts 4 lines in it.
After this you could calibrate the camera capture in Luban.

See section camera calibration:

Yup ! I sure did , I know have a collection of them and my wife wants to know where all her printer paper went , so I blamed the dogs !.
Although I don’t think she bought it .
Someone said something about the laser head having the wrong firmware but I really don’t know how to even start that case .
Those screen shots I took were straight after me doing the whole laser head calibration.
Snap help folks want me now to take a video of my attempt at camera capture , the screenshots weren’t good enough I guess , are they just wanting me to get pissed off and forget about the issue, all the help so far is “you need to click on calibrate or line up the dots ‘’that sort of thing ?.

Unfortunately I’ve been having a tough time with my CP recently and I can’t manage the stairs to get to the machine, so I might have to go through the whole thing again if my ticket expires.
May I ask which part of Austria you’re from ?.

Regards ,


Hey, before your ticket enspires, write a note into it so you don’t need to go through again.
I am from Linz in Upper Austria :slight_smile:

Hope you get better soon.

Greets Chris