Hand controller not moving x or y

I changed out my cnc head and put the laser head back on. The machine asked to up date the software which I allowed. The hand controller recognized the laser but when I tried to move the laser down, nothing happens. Can’t move anything anymore. I have reinstalled the software twice and still nothing. I put the cnc head back on and still can’t move in any direction. Luban is so frustrating but could rhis be a hardware problem?

Try to install the firmware again with a usb thumb drive on every module.

Hope this helps!

I will try it. I hate Luban.

Are we talking about the touchscreen or Luban?

Try a older Luban version insted of 4.4.0

The hand held touchscreen attached to the snapmaker. I can’t make it move in the snapmaker program either. I am unable to make it move at all.

I have reinstalled the software x2 and still no movement. I can adjust the laser strength but when I try to calibrate it, it just does not allow me to move it at all. Please advise.

Could you home your machine? - Before you didnt home you could not jog.

Did you try without a toolhead? - Are you able to home and move now?

Was your machine proper working before switching the toolheads?

Did you read this thread? My guessing is that you have to install a older firmware with the usb stick to give the modules the update ability.

If you are connected to Luban or a other terminal, watch the startup of the machine and see if there is a text about outdated modules.

I guess you are using the 1.6W Laser?

I am not able to home the machine, it’s just stuck. I put in a trouble request with the company and they have asked me to take a usb and download the files to them. It might be a bad controller but who knows. Will let you know what they say after they look at the files.

You didn’t answer the questions so it is nobody able to help you.

I am confused. I answered in my last email. No, I can’t home the machine. Also, I have downloaded the files to another person at Snapmaker. Who is my contact on this issue.

Here is the post, please read it carefully.

I changed the tool head and still no movement. I updated the firmware. I can’t home the machine either. If I have to go back and get an older version of the firmware, where can I download it? Here is the screen shot of the machine. The machine was working before I changed the tool head and did the software update.

Please make a photo of your homescreen, like it is after power up.

Afterwards power it off and try it again with no toolhead connected and see if you could move.

Here is the source for firmware downloads:

20221129_101239 (1).jpg

Here is the photo of the start up screen and a shot of the screen after the toolhead is removed. With no toolhead the hand controller defaulted to the 3d printer and behaved as if is attached. I am downloading an older version of the firmware to try and see if this will fix the problem

Barbara Cole
Attorney at Law

Unfortunately your photos (except one) are not visible in the forum. Lets see if a older ore more older firmware helps.

I was informed that the downloaded files indicates that the z axis is not detected. I was asked to disconnect the cables and clean which I did and still there was no movement. Next I uploaded an older version of the firmware and still the same. At this point I think it’s a hardware issue.

Wasn’t this kind of failure related to 1 endstop check (old) vs 2 endstop checks on newer firmware?

This happened under old firmware. Updated to new firmware and no change. Went back to older version and no change.

uh-oh…maybe something broke then…
Did you reset to factory values after firmware downgrade?

I tried to do that but every time I attempted it would give me an error message.