Flexible Filament adapter is needed


#1

it is nearly impossible to print flexible filament such as TPU with the default hardware. I have made an adapter that makes it easier. If this piece was incorporated into the heat sink inside the 3d module i think it would be a nice improvement to the filament feed. If they so desire the snapmaker team is free to use the piece I designed however they wish.

Link: https://www.shapeways.com/product/GWK9XQFS7/flexible-filament-adapter-for-snapmaker

My Settings for printing TPU are:

Layer height: 0.1mm
Initial Layer Height: 0.2mm
initial Layer Line Width: 100%
Wall thickness: 0.8mm
Top thickness: 1mm
Bottom thickness: 1mm
Infill: 25%
Print speed: 15mm/s
Infill Speed: 20mm/s
Outer wall speed: 20mm/s
Inner wall speed: 25mm/s
Top/Bottom speed: 15mm/s
Travel Speed: 40mm/s
Initial Layer print speed: 15mm/s
Initial Layer Travel Speed: 40mm/s

Enable Heated Bed: YES
Heated Bed Temp: 50C
Heated Bed Temp Initial Layer: 50C
Printing Temp: 200C
Printing Temp Initial Layer: 200C
Final Printing Temp: 200C
Diameter: 1.75mm
Flow: 95%
Enable Retraction: NO
Specialize the outer Contour: NO
Only follow Mesh Surface: Yes


Types of filaments being used
Experiment with TPE filament
E3D Titan / V6 Mount
#2

I just spent two days with two different types of flexible filament… and I’ve sunk in about $65 US dollars in media trying to get this thing to print. Out of about 1,000 attempts, I got the filament to thread about 4 or 5 times… but the filament would never print. When I draw the filament back out after a successful thread, I can see the end is melted… ( and I got the media to come through the nozzle during filament change) but the nozzle never seems to grab the media when printing… it clicks in a way I never heard while printing PLA. I assume there are some sort of rollers, or something, that feeds the media through the nozzle, but it isn’t finding purchase, so it clicks.

On 99% of my attempts to thread flexible filament, it seems to roll off to the side, and I can jam several inches into the unit… but it is just loose inside there. I assume that this is what JJEstings’ component addresses… but like I said, even after a successful thread, it would not pump any media through the nozzle – which seems like a separate issue altogether.

This is a pretty major oversight in the design of this machine. I’ve been really happy without how well the SM handles PLA… but this is a MAJOR downer for me… Over a year in testing and prototyping, and they never noticed this? I had several projects I wanted to work on that would require flexible media… and because it won’t print flexible media, it has taken a huge bite out of my enjoyment of this machine. It was a long time to wait for this kind of disappointment.

@Snapmaker - Please tell me you have a solution for this…


#3

i have got the same problem. It even takes more and more filament in, but it just stuffs it into the head without any threads coming out the nozzle. Have to stop each print with FLEXI manually.
Looks like some kind of problem with grabbing the flexi filament and feeding it through the nozzle.
bummed


#4

So I thought I’d add a few things that I neglected to mention in the first post. I made the part I designed available for free for people to download and print by following the link I put in my original post. you can also order it in other materials from the site if you prefer. Installation instructions are in the description.

Also a few things I found out while taking apart my 3d module. The inside consists of two parts, the filament feeder and the extruder. There is a large cavity in between the feeder and the extruder that makes printing flex filament impossible without adding a piece to reduce the space which is what the piece I made is for.

Also the feeder consists of a gear which is attached to a stepper motor and a roller which is attached to the filament change button (the one you press when adding/removing filament). When the gear rotates and there is no filament between the roller and the gear, the gear touches the roller directly and creates a clicking noise which is probably what moonglow experienced.

I have printed tpu around five or so x times since adding the piece I made and using the settings I posted and I haven’t had a single jam.

Also I’ll try to answer any questions people may have so you guys can start printing flex filament as well cuz it really is a great material.


#5

JJ,

I think it is wonderful that you found a fix, and you are willing to share AND help people. I’m just not sure if I’m ready to void my warranty yet… I’m debating… But I am impressed how thoughtful a gesture it is to make your solution available to everyone.

I do have a question:

  1. Would the addition of your device, in anyway, hinder the usage of more rigid filaments? I’m assuming you can still switch between rigid and flexible media (and back) over and over without any detrimental effects?

Thanks again.


#6

Perhaps you could get the SnapMaker team to certify your design. They may even want to incorporate it into production.


#7

To answer moonglum’s question, I haven’t had any issues with printing PLA with the insert installed and I have done multiple prints with each taking around 8 to 9 hours. The part in my printer is made of PLA btw.

Also as tone suggests I would love to have the snap maker team implement my design or at least certify it. But I’m not sure how to go about something like that (suggestions welcome).


#8

@jjestings I’m not seeing a way to download and print that part, only options to buy it. On one hand, I don’t mind spending the $16 for a polished steel part if it’s going to work; on the other hand I’d really like to print it in nylon as a test before I do so.

Thank you for the effort you’re put into this so far, I’m really looking forward to seeing it this works to print, at a minimum, TPU. Any thoughts on something like NinjaFlex working with this?


#9

I have the same issues whilst printing TPU as described in previous post. Although I was able to print TPU flawlessly a month ago, after switching back from PLA the feeder mechanisem is squeeking all the time while printing TPU, now. I also observed that filament gets pushed somewhere else inside the module instead of into the extruder.

@jjestings I would like to try your adapter, but I am having the same issue as @bCreative I can’t find the download link. As I haven’t disassembled the module yet, the instructions seem a little unclear to me. Maybe you could add some pictures of how it is supposed to look like when your part is installed. Thanks.


#10

You need to sign in to see the link.


#11

Thanks for the hint!


#12

Thanks for the input I’ll add some pictures soon. Also JHY is correct, you need to sign in to be able to download.


#13

@bCreative I see no reason why ninjaflex wouldn’t work. Haven’t used it myself but from what I understand it prints very similar to tpu so the print settings I posted previously should work. However ninjaflex is much more flexible than tpu so you may need to experiment the flow setting.


#14

Also JHY is correct, you need to sign in to be able to download.

Then sign up I shall

I see no reason why ninjaflex wouldn’t work.

YAY! I know someone who can send me a meter or so of it to play with, so I’ll see about getting my hands on some after I print and install this part and report back on the result


#15

Just added pictures on shapeways for the part, hope they help.


#16

Did anyone try TPE filament?

I’ve installed this adapter, but still not able to print with tpe filament.


#17

I haven’t used TPE yet, but have you tried lowering the flow percentage and the printing speed? The adapter gives the ability to use flex filament but the flow and print speed still need to be lowered to prevent the back pressure from jamming the 3d Module nozzle.


#18

Yes, I lowered the flow rate down to 75%, but the filament was still jammed.
Half of the first layer printed well, but that was all I could get.

I guess I should keep on lowering it, but I haven’t got time to do more tests yet.


#19

Could you post your print settings? Maybe it’s a setting that we missed.


#20

I was finally able to print something last night with the following settings


Except for 50% of flow rate, the 0.2mm layer height was also essential for it to work.

But there are some issues. The surface is ugly, and the infill is very weak. It’s actually like a sponge. I’ll give it another try tonight.