Dual extruder clogging and new "Replacement Kit for Snapmaker Dual Extrusion 3D Printing Module"

Just curious since it’s a little annoying. Why would I after complaining over and over to support and them trying to fix my clogging and slipping issue have to pay for this “kit” to fix a clear design flaw in the original head. Why is this kit not being sent out to those with open ticket issues.

No other industry would admit they had a design flaw on a top-of-the-line product and then except the customer to pay for the fix. Shame on you Snapmaker!

1 Like

Literally nothing wrong with the DX shipping now, if you bought the 1st Gen DX then that kit was free for almost a full year. If you never used the DX and waited this long and are upset because things changed after a year I honestly don’t know what to tell you. Maybe support missed your order with the email for the coupon for the kit last September, but they are the only ones that can check that info

I have an artisan, my machine is only 4 months old?

1 Like

When was it manufactured, because the Artisan has been out for almost a year and a half

Talking about this kit and the problems it fixes. The kit is not even 3 months old.
Replacement Kit for Dual Extrusion Module – Snapmaker US

My problem is not unique to me this kit exists to fix my problem. The problem has been written in this forum 40 times since artisan was released. Also regarding the artisan being out for 1.5 years…no didnt start shipping till march this year and i ordered long ago, last year.

1 Like

Yeah I get you think that is the timeline but its not, so…gather you let the module sit unused, which is fine did the same with my CNC, however they sent emails to order it for free, with free shipping to EVERYONE who purchased it with the A350 and Artisan, if you deleted it or if it got swiped to junkmail doesn’t matter now, I would get in touch with Jade in this forum she is an employee and if there is ANY possibility to help you she might be able to, NOT a guarantee though I just know she was who kept us informed while we all helped test the replacement design.

I found the email and forwarded it to support. Looks like they already notified me and i replied (actually 4 times i replied) with my address etc for them to send it out. But i never got it. Just sent them the entire email thread. I was on vacation when i replied so slipped my mind i had already gave them my info. That said still never received it so hopefully they can send it out. I have used that module or should say fought that module since i got the printer. Hopefully this kit solves the problem.

1 Like

That said, the replacement kit works, my DX is fine now. I suppose you can still get it for free.

I got an email response that said sorry you didnt receive but here is a link to the store to purchase. So i guess it no longer being offered as a fix for free. Not end of the world since its not crazy expensive but there should not have been a time limit on a fix for a design flaw and customers should not have to pay for that fix.

1 Like

Huh, I agree - that’s a bit disappointing…

1 Like

Check your emails, there should be a email to all users with affected double extruder with a coupon code to get the replacementkit for free.
Otherwise ask support about, can’t believe you have to pay for it.

2 Likes

Wow see thats why the community is great. Snapmaker is telling me i have to buy it, you told me about a coupon, so i searched my emails. Found it only cost me 1 dollar and the order is placed. Thank you!!

2 Likes

I got the kit on the snapmaker 2 - you have the snapmaker 2 right? i didnt install the kit yet, you say it works? :smiley:

I’ve the SM 2 A350 (no T or F), and I had heat creep problems with the unmodified DX, causing longer 2-filament prints to fail, extrusion stopping at some point. From the replacement kit I yet only installed the door (and I have the wedges installed, but not the glue-in-silicone-stuff; and only as a cautionary measure, I did not have popping levers, but wanted to avoid ever having them), but that changed the game and I can run long 2-filament-prints without issues. Looking at the filament after such a print, I see absolutely no hints of heat creep, so I guess for me it is fully fixed. I yet wait for my filament switches to fail before I install the new ones, just out of laziness TBH.

1 Like

For me it works fine (installed the door and rubber). So far no problems.

The sent the kits out free which was great. Mine works well.

I bought the dual extruder when it first came out and had the issue with 2nd head erroring on the filament run out when it wasn’t actually out. I opened a ticket and was told I would be sent a fix kit and just use M412 S0 in the meantime. The next week the 1st head started the same issue. I added that to my case. This was back in February or March. A month or so later I received an email the case was going to be closed because I hadn’t responded to the email stating a fix kit would be sent. The reply was they were behind on getting the kits out. I still haven’t received anything. I’ve about given up. I won’t buy anymore Snapmaker products.

1 Like

OK, did you delete the email with the upgrade kit coupon code making the kit free? They would have sent it to the email you used when ordering, we’ve been here working very loudly with SnapMaker fixing this issue why haven’t you checked to see if others had similar issues so we could help? Or at least so you could see that they were actively fixing it and also how said fixes were to be distributed? Showing up 11 months later and complaining? Really?

I never received any emails beyond promises that the kit was being prepared. The last one was in June. I don’t usually go to the forums to complain about support but after seeing recent posts about the issue I decided to add my experience. It shouldn’t be up to the user to continually contact the manufacturer about addressing an issue like this.

Nobody is continuing to, that, kept up with the issue, I think that’s what you are missing; besides the email, that was also posted when they would start going out. Which is why we told him where to find it or at least who to contact on here to figure out where the disconnect is, if you want to say hey I don’t see that email I see what every one above has said and I don’t have a resolution I just found out that’s one thing, but a it’s been 9 months since they shipped.