Door Detection Faulty

Not sure I fully understand your last option but I…placed a magnet on the door frame which matched the location of each sensor. Secured using duck tape strips …has worked so far.

I did this for all 4 magnets…

1 Like

Is the setting in the handset turned off too?

After I posted that line of questioning to you, I decided to try to mimic the magnet placement in the photo posted by @xchrisd — and I got success!

When I disconnect from Luban and check the setting in the handset, it says on, even if the reflection inside Luban (when connected) said the feature was off. Using Luban to turn it “on” and then “off” makes no impact on what shows in the handset on the Snapmaker 2.

Not sure if this one…does the laser work with doors shut and then stop when doors open…if so I would leave it at that. J

1 Like

the latest controller firmware has a bug which means the door detection can never be disabled

1 Like

I’m on the latest firmware for the controller, so I must be up against that bug. Thanks.

Same problem here. My magnets were a mess out if the box. Reposition them and viola. I need to adhere them with something stronger though. They continue o jump from one door to the other. Clearly the tape on the other door is better.

hmm, i havent put mine together yet to know what hte issue is, but i will say that there is some UV light glue that i am really happy with using - you can get a small one called bondic that might do well for that

i am graduating to loctite and a better light now.

I print, mill and laser the most things from the touchscreen, you have to disable the door detection in the enclosure settings. - Yes before every cnc or laser but it works.

What firmware version are you on - 1.10.1, and possibly others, have a bug where you cannot disable, at least on mine and seems like on @buzzplops as well.

I just tape the extra touchscreen mount on the sensor - the spacing exactly matches the door magnets lol, and makes the controller think the door is closed.

surprised you would do that, rather than fix the bug, its only ~2 lines :stuck_out_tongue:

Cause I’m waiting on your pull request to get merged lmfao

I’m genuinely tempted to start a parallel branch with all of the pull requests merged, since this takes forever

(in all fairness, I’ve not submitted one. Highlighted the issue, but didnt think it worth a PR, figured @staff would just fix it… d’oh)

I use the latest firmware and have a cnc project now, so not tried doordetection with laser and actual firmware yet.
The point is, I guess, you have to disable it before the job from the device you want to mill from (touchscreen).
Disabling in Luban doesn’t work if you don’t mill from it.

The enabled flag is never set to false, the door-open event is always processed

Whatever you want to show me in the code,- from the touchscreen the on/off doordetection works.
With Laser and CNC as well.
Try it out.