CNC not starting with Fusion 360

Hi all,
I ran into an issue today when trying to use the CNC module. I followed the same steps as I normally do, but ran into a problem when executing the G-Code. Basically, as soon as I hit start, the module spins, but does not execute any moves.

Has anyone else had this problem?

Note: I have used the CNC module with Fusion 360 before so I am confident my setup files are working correctly. I even uploaded the file to Luban and both sets of code look correct (match the simulation is Fusion 360).

NorthSeattleWaterFirst.cnc (45.1 KB) NorthSeattleWaterSecond.cnc (2.3 MB)

Thank you!
Michael Hudson

Double check your feedrates. You’re feeding at 20mm/minute. I’d wager it is moving, just extremely slowly.

1 Like

Also safer if comment lines start with a semicolon, the comments in your file start with a bracket.


Interesting. Thanks for the heads up on that. Honestly these are generated straight out of Fusion 360. The comments were automatically generated there.

I have tried again and watched it for over a minute and there was definitely no movement. I will try an old G-Code to see if it still runs.

OK In that case, I have another guess.

You said the tool turns on so it’s getting through line 5 M3. The first motion occurs on 12 with:
G0 X-2.540 Y30.639 Z15.000

There’s no feedrate specified there. Try adding a F1000 at the end of that line, see if that changes anything.

Maybe the machine is interpreting that as a 0 feedrate.

1 Like

Thanks for the help brent and albutch! I compared the old and the new files from Fusion 360 and found the paragraph about rapid movement was a difference. Once I removed that, the snap-maker took-off and did everything I was expecting. Much appreciated.