Artisan CNC ignoring speed from Fusion 360 file as well as stop action

Hello All,

Trying my hand at CNCing a dicebox. Made the model in Fusion 360 but ran into a few issues.

  • If i set the spindle speed to 12000 rpm, Artisan will run it at 18000 rpm.
  • I add in a ‘force tool change’ action but the Artisan seems to ignore this as well.
  • Seeing some fraying but this might be a wood vs bit issue.

Has anyone dealt with any of the above issues?


I bet it’s something within postprocessing, the g-code commands are mixed up.
Did you use one of the postprocessore from the list GitHub - shurushetr/awesome-snapmaker: Curated list of things that help you make something awesome with Snapmaker machines.. ?

I know the free version of F360 limits the jog speed to the work speed. I used the Terminal app on my Mac and the sed utility to replace all the G-code for jog operations with faster speeds.

1 Like

No i’m using the post processors that Snapmaker provides

@nweolu I’ve used some of the post processors out there but the artisan seems to just go at it at 18000 rpm. I; suspect it’s also ignoring the feed rate which is causing friction burns and the bit to actually get stuck in hardwood.

Any further insight?

It might be indeed the issue with free version of the Fusion360, like TheBum suggested.

Check out this thread - Available Now: New post-processor, tool library, machine configurations, for Fusion 360

It has details about the issue and a workaround described in details.

You can post the cnc file here, so members can take a look and verify the fusion output. If you not familiar with gcode.

Free version just limits it from doing rapid moves (which are easy enough to remove with a text editor and ‘find and replace’) If anything it would cause less problems.

Need to share your g-code to be able to see if anything strange is going on. Looks like there’s a strange entry point on lower right.

Also what type of bit and feeds and speeds are you using? For a smoother finish with less tearing you want a downcutting bit.


1 Like

I think this is the most current file that I have. Cant find the other ones I’m afraid but i’m pretty sure they all had the same issue. If it helps I do have a license for Fusion 360 but maybe the file was made with the free version before i registered?

@sdj544 @nweolu
1001.cnc (1.3 MB)

@nweolu @sdj544 polite bump

1 Like

This little tab, is it related to the black gauge in the corner of your work piece?

P.S. I used to visualize this.

Thanks, @nweolu . That site is pretty handy,

The black gauge is where my bit went off the path and burned out due to friction. I think it’s because I used a single flute and the wood chips weren’t cleared properly. Pretty packed in.

Where can I see if the speed was set?

From the cnc file you posted it looks like its just doing a narrow spiral to the bottom and then going in outward rotations at the bottom.

I know the Artisan is much more capable than a 350 but I’m surprised you got it to do as well as it did and didn’t break a bit.
On an SM350 you can only do .5-1mm step-down depending on the type of wood. With the Artisan I assume you can go 2-3mm at least, but still not anywhere near what it looks like you’re trying to do.

Also wondering how you’re setting your work origin because it looks like the g-code is running paths with both positive and negative numbers. Usually you want your origin at the top of the material which would mean you’d only see negative numbers except for retraction and moves. Or for some instances you might set your work origin at the base of your material, and then you’d only see positive numbers. As long as how you’re setting it in Fusion and on the SM are the same, it doesn’t really matter, but just found it odd.


@sdj544 Thanks for your reply.

I basically used the default settings. How do I improve this? More steps?

Did two things:

  • I set the origin to the center of the buildplate.
  • I gave the stock the correct dimensions and placed the bottom of the stock at 0,0

Is this the incorrect way of setting up the CNC for Snapmaker?

You can’t assume that any settings in Fusion are default. It doesn’t know the capabilities of your machine. Not sure what you should set step-down for Artisan, but I would start with 2mm and see how it does.

In your gcode it shows power as P100, which would run it at full speed. You can edit the gcode manually and change it to P70. Not sure why it isn’t doing that automatically. (You can also try S12000, but not sure if Artisan recognizes that) I assume you’re using an Artisan specific configuration file for Fusion?

SM firmware doesn’t support tool changes. Have to export and run as separate files.

That looks correct. I think I misread the Z values.


1 Like