CNC Motor does not start

Hi all

it seems I have an issue with my CNC head. I worked fine and I did a few engravings and I am impressed by the result. Then it happened that the motor did not turn on. Sending M3/M5 return OK, but the motor does not start., trying to turn the motor directly on Snapmaker hast no results neither.
I checked with laser and laser turns on and off as desired. Checked the cablwe to the motor and it seems to be good. Is this now a issue with the motor or the electronics?
How do I get this repaired?
How can I order a new CNC device, as I am afraid that the 90 day warranty is just over.
Any ideas are more than welcome.


1 Like

Contact and overworked @Rainie

Have a great day


Thank you Doug. Very much appreciated.

I also got that problem and opend up the cnc-Device to check the motor. I Found out the the PCB within the Motor cover was twisted, so the connector was lifted up a little, what had removed the connection as well.

Solution was to twist the motor pcb back in Place an tested it again. It worked again.

I finaly keeped it in place with some silicon. Do not how long this will work but for now it does.

It would also be nice to know the motor control and motor can be ordered for the worst case.

Kind Regards

1 Like