CNC carving head stopped working :(


#1

Hi,

I have my Snapmaker for some weeks now and now tried using the Carving head (after some 3D printing and very little Laser engraving).
I cutted some names into Lego Bricks (nice thing on thingiverse for this) and also tried it into wood.

Now, after some hours trying the CNC carving head stopped spinning. Or in more detail. It is spinning very slowly for some seconds and than stops. After this, also most of the functions related to the cutting head aren’t working anymore (restart the spindle. Or starting a new cutting from file. If I do so, nothing happens). So I assume some failure protection in software?

When I try to rotate the spindle by hand it runs quite easyly and free. Not totally, but I assume, the motor itself is also generating some resistance itself (it feels exactly like this). It is only very little resistance.

I connected the printer to USB and tried starting the spindle from SnapmakerJS (was using carving from USB-Stick files before) and the output in the console showed:

M3
ok
Error:MAXTEMP triggered, system stopped!
Error:Printer halted. kill() called!
other < Err: MAXTEMP

What should I do? Of course I tried switching it on and off already (doesn’t really help, it is only “resetting” the some second slow spinning). I could open the CNC carving head, no problem, but I do not know what to look for (would need some guidance for this). Everything seems alright from the outside, actually nothing looks broken (or smells broken, you know like cooked electronics) perhaps I only do a mistake (but I do not think so, because I have done multiple carvings already).

Best regards

Benedict

PS: BTW it would be great if it would be possible to copy the content of the console in SnapmakerJS! I had to rewrite the Error by myself, because I couldn’t copy & paste it :confused: This would make failure reports much easier in the future (and more failure tolerant. Now I could have written down something wrong. I double checked :wink: )


#2

Hi @Baxerus,

Thank you for your feedback. Please follow these steps to troubleshoot:

  1. Power off the printer. Change the CNC carving module to the laser engraving module.
  2. Power on the printer. On the touch screen, go to Controls > Laser/CNC Off to turn on the laser.

If the laser engraving module cannot be turned on, the controller is defective. If the laser engraving module can be turned on, please detach the left side cover of the CNC carving module and check if the below cable is loosened. If it’s not loosened, the CNC carving module is defective.

Meanwhile, please fill in the warranty request on our website. We will send you a replacement once the problem is identified.

Look forward to your reply. Thank you!

Best regards,
Rainie


#3

Dear Rainie,

thank you for your answer. I assumed that you had vacation because of the Chinese New Year (btw Happy New Year :fireworks::sparkler::tada:).

I already tested and used the Laser engraving module after the CNC module stopped working (for about a dozen engravings or so), so it is working without problems.

I will check the connector inside the CNC module when I am home at the printer (still today) and answer back, if the connector was loose.

I also created a warranty request (linking to this forum topic)


#4

Dear Rainie,

I checked the cable, everything looked okay. I tested again, but still only spinning slow for some seconds and than stopping.
I tried unplugging the connector and plugging it in again. Than a new test, still only spinning slow and stopping.

Unfortunately it seems like it wasn’t only a problem with the connector :frowning:

Should I try something more? Measuring something or so?


#5

Hi @Baxerus,

Thank you for the information.
According to your description, we can be sure that your CNC is defective. I will send you an email about the replacement using support@snapmaker.com.

Thank you for helping us identify the problem.

Best regards,
Rainie


#6

Hi Baxerus,
I also had a problem with the CNC module, exactly the same as yours, just out of warranty as well.
I was foolish enough to try to repair the module myself (Do not try this!) and when I connected it to the Snapmaker again it simply overheated and literally melted the connector!
This resulted in the controller ceasing to function.
I have recently repaired the controller and all is now well in the world. I no longer need a CNC carver because I purchased a 400mm bed model from Roland, but I am again using the Snapmaker 3-D printing and Laser Engraving modules.

If you were as impulsive as I was and attempted to fix the CNC Carver motor, your controller is also probably damaged now. Here is how I repaired the controller:

Remove the outer cover from the controller. On top of the PCB in the corner there is a row of components which I believe are MOSFET’s (in metal casings).
Next to these MOSFET’s is another, rectangular one in a plastic casing. Two legs are soldered down and the third contact is the heat sink. This is the MOSFET that controls the output devices; CNC Carver, 3-D print head, Laser engraver head.
The MOSFET is an ‘NCE 3050K’ device. I did various searches and could only locate one on a site in China. I ordered 5 (minimum order) and when it arrived I replaced it and all is now well. It is an SMD device so needs lots of care when removing it and soldering in the replacement.


#7

Dear Old Dog,

no I didn’t try to fix it by myself (yet). I’ve kindly got a now one as replacement part.
I tried to get a replacement motor, but wasn’t able to find the proper one.
So no damage done on my machine. But many thanks for you trying to help me, a stranger! Should be done more often in the community :+1:


#8

Same problem with mine. Just tried the CNC for the first time after having it sitting forever after my 3d printer stopped working as well. CNC did about 5 small test carvings and quit working. So now I am reduced to a laser engraver that is only 200mw and doesn’t engrave anything. I am feeling pretty ripped off at this point. Software is awful. Nothing but problems. Anyone else?


#9

Everyone will have these problems if he overtaxes the efficiency of the engine. Only equipment for professional use is suitable for continuous operation. What do you believe what “MAXTEMP triggered, system stopped!” means ?
https://en.wikipedia.org/wiki/Duty_cycle


#10

My CNC head actually never STARTED to rotate. We tried to design a simple shape on wood with a SVG file, followed all the tutorials provided on the website, but still, when we start the carving, the head follows the line of the design, but without rotating and eventually get caught in the fiction with the wood and bend dangerously. I don’t see where it could come from, except a dis-functioning from the module.
Thanks for your help