CNC Spindle stopped spinning

Been loving the Snapmaker 2 (large one).
And have been CNCing a bunch of foam molds. However, half-way through a job today the spindle stopped spinning!

Everything else is working fine. But the spindle stopped. Here’s what I’ve tried:

  • Restarting everything.
  • Running older jobs that I know worked before.
  • Replacing the collet, and the bit.
  • Checked all the connections to the controller and to the cnc head.
  • Removed the side of the CNC head and checked the connections there.
  • Sent M3 and M5 commands to the machine via luban and got back “ok”
  • Changed spindle speed to 100% from 50% in settings.

What’s weird is that Snapmaker reports “RPM 0” when the job is running.
Can someone please help me with this. Much appreciated.

Well, it sounds like it’s accurately reporting the actual spindle speed. Contact the manufacturer for a replacement work head.

1 Like

I’m running a long print so I can’t check right now.
But I believe you can manually turn on the spindle from the control pad. (
Have you tried that?


I haven’t. How do you do that?

Really? You can’t figure that out yourself?

Try looking under the control settings. Should be a spindle speed choice where you can turn it on.
I don’t have cnc set up now to check.