Can't connect A150 to my MacBook Air M1 via USB cable

Hi guys,
I’ve just tried to connect the Snapmaker 2 A150 to my MacBook Air with the new M1 ARM64 chip but it seems doesn’t work using the USB cable.
Can someone with the M1 Mac try?

I am using a similar setup (M1 MacBook Air + A350) since 6 months without any issues.

So you can send M503 command via WiFi and get reply on console?
Or are you using USB cable?

I am using WiFi to connect to the A350

Im using A250 without issues.

Just tried:
connected my A150 via WiFi and sent M503 from console… just OK as response! :frowning:

That’s normal. You have to use a USB cable to get a real response in the console—it doesn’t send responses via wifi. It’s how Luban was designed. No, I don’t get it either.

Ok so… does anyone connect the Snap to the new Apple M1 via USB? I’ve tried but it seems that doesn’t work for me

Okay, so let’s cover the easy questions:

  1. Are you trying to hook up through the correct port? The A150, like all Snapmaker2 models, has a USB-A port where you plug in USB sticks, and a USB mini-B port, where you plug in to connect the console to a computer. If you’re trying to connect through the USB-A port, it won’t work.

  2. Do you have a driver for the USB conversion chip in the A150? (It may be built in to the system for Macs, I’m not sure, but I expect someone here will know.)

Auch!!! I’m really sorry sometimes I hate myself!!!
I’ve tried connecting using the USB port where I connect the pendrive. :frowning:

My fault sorry, tomorrow I’ll give it a try with the USB mini port.

Sorry guys!