Cannot connect to A350 with a USB

Hi Im having trouble with connecting to the A350 by USB it just does not show anything at all, nothing to be able to tell why it won’t connect.

@Michael1 you need to install the CH340 drivers on your pc

Hi Artezio I tried loading the driver but it did not seem to load it just preloads and will not go any further

If you can’t install the drivers from here then maybe contact support or post screenshots or something. I am not aware of any issues with the drivers, they have been unchanged for many years now.

Hi Thanks for the feedback yeah its pain but hey just won’t load Its a new computer with windows 11

Some quick Googling indicates those drivers should work on 11. Maybe the install process is just broken.

If you have 7zip open the .exe installer as an archive and extract the files:

You should be able to then go into device manager

See if there’s an unknown device. Do a manual install and point it at the extracted .inf file.

If you don’t have 7zip and trust files downloaded from the internet here’s what I just extracted: (142.9 KB)

Alternatively, and probably more simply, you should be able to right click->Install on the .inf file

1 Like

Hi Brett113 thanks for the help,

This is as far as i seem to be able to go

You have file extensions hidden, no matter, right click, install:

Ok I think I got that done, is there another step that would need to be done

You do need to be using a usb mini cable to connect to the mini port on your SM.
One came with your SM.
Just wanted to make sure since other people have made this mistake.


Should be it. Does it work? If not, is it showing up in device manager (see above screen shot) either as an unknown device or under Ports? As you plug it in and unplug it you should be seeing something show up and go away in device manager.

Okayyyyy It works, thank you for the help its much appreciated.

I have been using win11 just fine with my A350 for months.
Glad you fixed it.