Camera is not working?

as today i tried to use my A350 for the first time,
i wanted to start with laser engraving.
Followed the guide,
but the camera could not autofocus, so tried it several times, but the camera light on the screen is still orange…
As well i cannot get pics in the software of the G code generator.
Any ideas how i can get it green?

After serveral more tries, and switching on off,
the camera is now green on the display, but doing nothing.
Position left side on top.
When i try to get the photos for the panorama,
the button gets blue, but nothing happens.
No movement, or pics…
Thats a bit frustrating for the start…

Once more switched off / on,
now the camera is orange again and i cant get the Wlan connection, the button for it is not on the screen of the Luban software…
And the button for taking the photos for the panorama is missing to…

Found the connection button,
but now the Snapmaker is missing,
cannot be detected in my wlan???
Tried 3 times on / off,
but still missing?
Thought it will take time to get into it, but when getting a connection is a problem,
thats not what i suspectet…

any ideas what i can do to make the camera work?
Still orange and no pics possible…

  • You need to make sure that the touchscreen has connected with the Wi-Fi, as you can see the WLAN’s name in the top left corner of it.

    • If you are using the latest version of firmware, you can check the IP address in “Settings”.
  • You can also choose the WiFi in the Connection Widget in Snapmaker Luban by clicking the icon of “refresh” and check if the software has connected with the Wi-Fi.

  • FYI: If the camera status is not green, which means camera is not available now.

  • If the camera is not usable, the button of camera capture is not able to be clicked as well. According to your description, you can click that button when the camera is inactivated, that may a bug of the software, and we will try to reproduce and fix it.

have tried serveral times to calibrate, laser works, but not the cam.
After going over settings - laser - camera it cutted the square, but then got stuck.
After 10 minutes i shut off and on.
Now it shows me “no camera connected”…
After next off / on it said no tool head installed, so i unplugged and replugged the head cable,
after the next 3 times off on, and a new laser calibration,
still “no camera connected”…

Wifi works now.
Have an extra light installed for the camera, because i thouhgt maybe not enought, but no difference.

have let run the SM, and then i passed it some time ago, found the camera light green on the controller.
So did a new calibration run, but it happend the same. Did the square, but then got stuck…


A350 camera capture not working here too. It gets stuck halfway through. Here’s a screenshot where it gets consistently stuck. Any suggestions? I upgraded Luban and firmware to latest versions.


Did you see any notifications pop up when it got stuck? It will get stuck when the Wi-Fi connection is dropped.

No, no notification. WiFi connection is still one. The freeze is very reproducible: it always freezes at the same point in the image scan. I tried it 5 times. It feels like a software glitch since otherwise laser and camera seem to be working well.

Please do as following steps and send me some feedback.

  • Use the camera capture function, and there will be a sign “start”. Do not click it and do as followings.
  • Click in order like this “View” --> “Toggle Developer Tools” --> “Network” --> “XHR” --> the icon of “clear”
  • The click the sign “start”
  • Filter the result by photo. find the stuck and send me the screenshot

In addition, you can check whether there are obvious red errors under the console

1 Like

stil no camera…
Is there any way to test what can be wrong?
Dont want to open it by myself…
The Luban is making nothing if i try to import files, or only strange circles…
Have tried .svg from inkscape, jpg and dxf.
With the last one, i starts, but runs until i cancel it…
And it gives my a wrong date, allways means 2020.2.2 for today…

That is not exactly what i wanted to have…

Wolfgang, send me your email or contact

Please try to connect Wi-Fi and then check if you can use it.

first try today,
it shows camera green, light is working, try to calibrate, laser works, but then gets stuck during autofocus processing
second try,
camera is orange, no light, autofocus failed,
third try,
camera green, light is working, gets stuck while autofocus processing,
fourth try,
camera is orange, no light, autofocus failed…
Will try now to engrave the symbol i have, and see if that works out

It is indeed helpful.
But I am asking you the file transferring via Wi-Fi :rofl: :rofl:

One user encountered the same problem,you can check if the camera is not installed tightly

have done the first engravings yesterday, works via wifi, can remote the working platform, and start / stop the project.
Should the project file afterwards be in the android device as file as well?
Or is there any other way to save it there, except usb transfer?



have opened it,
cables and connectors look good.


1 Like