Laser camera capture?!?!?! SM2 A350

Ok, I’m new to this, had my A350 since the day before Christmas. Trying to figure out the laser camera capture. I’ve tried the example in the manual and the video both total failures.

The manual and the video both imply that using the camera capture allows you to mount your material, connect via Luban, load your image, size, and move it to the location on your material where you want it to burn.

This does NOT seem to be the case! When I load my image in (so far using the “gift box” after doing the camera capture several issues occur:

  1. on loading the Gift box, it is very small each piece seems to be about 5mm square. I can expand it and place it on the picture where it would go.
  2. If I process the file it ends up in the upper right quadrant. If I try to run the boundary it is showing the boundary way off of the work platform! Which is mostly NOT on the material.
  3. After playing around with the “work origin” and boundary checks, it still tries to print beyond the work table.

I finally figured out that BEFORE you process the file you have to close the background (the picture from camera capture) and move the image so that it is centered on the 0,0 axes on the Luban display. Then process and create the G-code.

So apparently the camera capture ONLY is good for sizing your image?? I also had to play around after saving to the device, with work origin and check boundary.

Seems like for the amount of $$$ we should expect software and tutorials that actually work. I’ve seen several posts here in the forum about using Lightburn, I downloaded it and there seems to little if any support for the SnapMaker, I did try to set it up per a post I found either here or on LightBurns forum. Tried using via USB serial connection, and can get the x,y axes working but the Z-axis tried to drive the laser through the work platform, fortunately, it did not seem to harm anything. And contrary to one post I saw LightBurn does NOT support the SM2 camera. The SM2 camera only works via WiFi and NOT USB/serial, and LightBurn does not support WiFi, only USB/Serial.

Any feedback? I’m open to suggestions on getting the camera capture working correctly in Luban or even better setup for the A350 in Lightburn.

HI, I’m not sure that you are doing things correctly, or there is a calibration step you have missed.

  1. Sounds normal. You can have a large or small gift box, you change the size to suit.
  2. Yes my background image is always in the upper right quadrant, and then I right click hold to move the entire grid and picture to take up the view screen properly and then mouse wheel to zoom in our out.
  3. I don’t play with the work origin at all as I am using the camera method for placement.

I only delete the background picture if I have moved/changed the object to be printed on, then I recapture again. I don’t do it before ‘process’.
Have you done the calibration with the square on the piece of paper, which is just once for each time you have the laser mounted? Also set the material height before each job?

Like PDXMike, I received my A350 just before Christmas and I am having problems with the “Camera Capture”, however, it appears that my camera is not functioning properly. This is my 1st attempt at using this feature and I was anticipating some frustration in determining the exact method for getting it to work properly.
I need to back up slightly to mention that I have done the laser calibration several times in preparation for engraving on a different material or use a different image, etc. The auto focus always fails, but I never gave it a lot of thought as I have been able to proceed using the manual method and have gotten very good results. I have also done the camera calibration a few times, but realized that I have never seen the light function. The machine always cuts the square perfectly, but there is no real indication that the camera is truly calibrated.
My last attempt to capture the image resulted in 9 images in the workspace which didn’t appear to have any rhyme or reason other than being unsequenced, distorted parts of the original picture. Has anyone have this problem? Do I need to have the laser module replaced?
Another nagging issue is with the wi-fi connection - it will not stay connected. Thus far I have been able to live with it, but is often and unnecessary frustration while trying to setup a project. I have seen other references to this problem; has anyone come up with a cure?

Thank you

I’m assuming you’ve updated the firmware.

Try turning off all lights and doing the camera calibration.
People have reported having better success with just using the light on the laser head. I know you said the light doesn’t seem to be working. This way you’ll know for sure.
Before you do this double check the pins on the cables and the sockets (with the power off) and make sure they’re well seated.
If the light isn’t working, contact support.

One last thing you could try is loading firmware 1.9 and see if that makes any difference.

1 Like

I have done as you suggested and rechecked the cable connections and the camera light with the room lights off; it is working. I then installed firmware version V1.10.1 and tried setup of the various functions to use the camera capture which seems to have gone well. I did notice that I should ensure that the picture is as square with the table as possible otherwise the individual photos will be skewed causing issues with the final picture.
This brings up another question: what does the “Remove Background” button do? I thought perhaps it would remove the table and leave just the picture, but it appears to remove everything.
V1.10.1 appears to have fixed my problems with the camera, but I have not tried to complete any projects so the jury is still out.
Thank you for your help and have a great day.

This means you have not completed the calibration properly. Going back to the square that was printed ok, when you view it on camera in calibration there should be a digital line over the top. You need to zoom in and move the digital line to overlay the square as perfectly as possible. Then those 9 images of the workspace will perfectly aline also.
You only do this calibration each time you install the laser head unit, not for each material. The ONLY thing you need to change per material is the thickness of the object and the laser power for each job…and of course where the burn/cut will be goes without saying.
I use the ‘remove background’ if I want to move the object and then get the camera to take the 9 image shot of the workspace again, thus giving up to date positioning and giving a new background picture to work with.

1 Like

Thank you, I appreciate the information regarding the “Remove background” button. After updating the firmware the camera capture function worked much better.
If anyone has a fix for computer software disconnecting with the machine I’d love to hear it.

I am having the exact same problem as PDXMike. I have done the camera capture and calibrated the image to match the cut square. When the camera capture comes up it shows the image of the work table in the upper right quadrant of work area and not centered. I use that for size then have to move the artwork to be engraved to the center of the work area in the layout and not over the captured image. If not, the machine will try to engrave off the table. I noticed this issue with the 3D print module as well. But in the case of the 3D print even if it shows in the center of the upper right quadrant, it will print in the center of the table. My firmware is up to date with the latest version

YES!I just turned off the led lights to my enclosure. Worked great! Man It was driving me nuts!

I think I just experienced the same problem. When I would run the boundary it would be off the laser plate… vs what I was thinking I set up on the camera capture.

It was the job settings, I would set the origin at “Center”, then do the camera capture… which would be set to Left Corner… so even though in Luban I had set the job setting to “Center” the camera capture would be set at Left Corner so when I would generate and run boundary it would think it was the left corner… Not sure why its doing this.