Camera Capture Not Working

I was using the laser modules yesterday and had no problems with the camera capture. Today I went to use it and when I clicked camera capture, add background, start, the module got into position and then nothing happened. No pictures were taken. It just froze at the first picture location. I restarted my computer and the Snapmaker and the same thing happened. Ideas?


I have the same issue. Have you sloved it?

I always put a white A4 sheet of paper under my object. And close the door of my housing against extraneous light.

High contrast things like some a4 paper works some of the time I’ve found but not all of the time.
My solution has been to just not use the camera capture feature…
Too much of a pain with this bug.

I have the same issue. The camera will not scan after installing the update - meaning the most current update

I have the same issue. Installed the update and camera capture does not work! Brand new machine. It would be nice to see it work.

You can revert the firmware back to 1.13.2

But camera capture doesn’t really work even when it works. Terrible implementation.
Better, faster, more accurate ways to position your work.


I have the same problem with the camera. The function worked only once. Most of the time the device stops at the start position and does not take a picture. If you calibrate very fresh it makes maybe 2-6 pictures and stops afterwards. I can’t reproduce the error stably, or discover a sure way to make it work. In addition, the device usually loses zero after a failure - this is very frustrating. Is there a stable version of the firmware and Luban that could be used? I am grateful for any help.

Support has been informed, but seems to be on vacation until January 3, 2022.

Update 02.01.2022!

I have downgraded the controller firmware to version V1.13.2. And lo and behold - the machine does what it should.

I had meanwhile also developed a workflow so that this also works in version V1.14.1, but this is not stable and works only 2 out of 3 times. It seems to be several workflows for machine, which the machine can not finish in the network - and hangs itself, because the set zero point disappears. Anyway, I managed to get the camera to load the images without having a connection according to Luban. Very strange.

Tomorrow I will test the milling function. Fusion 360 is already configured and I will get more milling cutters from my company tomorrow. The tool library provided is incomplete, as far as I have seen, and the cutting data for some tools is partially identical. I’ll have to take a closer look at that.

Translated with (free version)

Original in Deutsch:
Ich habe dasselbe Problem mit der Kamera. Die Funktion funktionierte nur einmal. Meist bleibt das Gerät an der Startposition stehen und macht kein Bild. Wenn man ganz frisch kalibriert macht es vielleicht 2-6 Bilder und bleibt im Anschluss stehen. Ich kann den Fehler nicht stabil reproduzieren, oder eine sichere Vorgehensweise entdecken, damit es funktioniert. Dazu kommt, dass das Gerät meist nach einem Fehlschlag den Nullpunkt verliert - das ist sehr frustrierend. Gibt es eine stabile Version von der Firmware und Luban, welche man verwenden könnte? Ich bin für jede Hilfe dankbar.

Der Support ist informiert, scheint jedoch noch bis 3. Jänner 2022 in Urlaub zu sein.

Update! 02.01.2022

Ich habe die Controllerfirmware auf Version V1.13.2 herunter gesetzt. Und siehe da - Die Maschine tut was sie soll.

Ich hatte mittlerweile auch einen Arbeitsablauf entwickelt, damit diese auch in Version V1.14.1 funktioniert, aber dieser ist nicht stabil und funktioniert nur 2 von 3 mal. Es scheint sich um dabei um mehrere Arbeitsvorgänge für Maschine zu handeln, welche das Gerät nicht beenden kann im Netzwerk - und sich daran erhängt, da der gesetzte Nullpunkt verschwindet. Jedenfalls habe ich es geschafft, das die Kamera die Bilder lädt, ohne dass laut Luban eine Verbindung vorhanden gewesen wäre. Sehr seltsam.

Morgen werde ich die Fräsfunktion testen. Fusion 360 ist bereits konfiguriert, und ich werde morgen weitere Fräser aus meiner Firma holen. Die zur Verfügung gestellte Werkzeugbibliothek ist, soweit ich gesehen habe, unvollständig, und die Schnittdaten für einige Werkzeuge teilweise ident. Das muss ich mir näher ansehen.

I haven’t tried using the Lazer prior to 1.14 being loaded. I did notice in Luban that the Lazer, Enclosure and Emergency stop button are listed but not the enclosure, while one the SnapMaker screen the camera is also listed.

How do you position your work then?

A few ways:

Mark the center on your workpiece and align dot (either moving workpiece or head/bed) with that. (use tape if you don’t want to mark up your workpiece)

Use the cnc bed. I made a series of squares and circles and lightly lasered engraved the cnc bed at default work origin. Works really well for coasters.

Use run boundary.

Go to the edges of your workpiece and figure out distance you want it from edge plus half of dimensions.

Go to edges of your workpiece and make a note of coordinates. Do a little math and you can figure out the center coordinates.

You can also use some thick card stock (file folders work great) on top of your workpiece and run a test run at lower power (so it doesn’t burn through). This works really well for combined cnc. You can do a pencil/crayon rubbing to show what’s underneath.

I’m sure there are a few others, but these seem to cover pretty much everything I do.


1 Like

Same with my machine. Does yours work again or still not working?

Just tried the instructions on page 73, laser head moves to mid-point then nothing. WiFi connection is solid, however, when you add background and click Start, it sits there and the laser no longer moves. Being a brand new user, I’m guessing this appears to be a combination bug in the hardware and Luban, right?
Upgrade software for control and laser and using version 4.1.4

This is very likely that they messed up the camera capture for the 1600mw laser when doing the 10w laser. On the 10w, the laser uses a new wide angle camera to take the picture without moving.

Very simple tip at least for those who use an enclosure.
Before recording the laser area, please turn off the lighting of the enclosure and everything works fine!


Noticed system had an upgrade waiting on the Touchpad so downloaded it and now the capture works, the only issue is when you laser their sample project, even after setting size of work area and home, if you have it run the boundary it runs the entire surface, and if you start the project instead of going to home it wants to start at the back right corner and fires the laser. If you turn backgroun off and print using the same file it works perfectly.

Ha!! Coolest tip I’ve seen in a while! Glad I continued reading. I do have an enclosure and had this camera capture issue. So, folks, if you have an enclosure, this one is for you.

Thank you.

Great advice! I tried that and it works fine :wink: Thanks

Just ran into the problem as well with the 10w laser. I was connecting via USB and the background button was inactive. Switched to Wifi connection and it worked…

In the Workspace area when I do USB connection the camera does not show up at all where it shows all the active modules (it does on the touch screen with a green button).

It does show correctly when using wifi in Luban… Clearly a bug…

Running Firmware 1.19.0… Luban 4.12.0

So the fix is (a) turn off the LED enclosure light strip and (b) use Wifi connection…