Calibration pushing deep into buildplate

I got my new Snapmaker 2.0 today and assembled it already.

As far as I can tell, everything is connected as it should. All axis move, filament loading worked well.

But the calibration seems to be completely broken. Point 1-3 seem to work but it presses the head quiet a bit into the buildplate. It’s even worse at the back. At point 5 it pushes the head into the buildplate until the steppers start to skip steps. The nozzle left a deep mark in the brand new buildplate. At this point the process stops and the head moves in the middle of the plate. It just skipped the other point.

I updated the firmware to the newest 1.6.0.0. Result is about the same. Sometimes it moves the head into the bed and sometimes it “probes” way up in the air (10cm above plate).

Nevertheless. It’s unusable in this state. Build quality is fantastic and I hope the other issue is only a firmware issue.

Be warned, this firmware issue presses bad marks into the magnetic buildplate and may also harm the nozzle! There may be an issue with the detection of the distance to the buildplate but I could not find any information about how this works. So no chance to fix it myself.

So, two hours after receiving the package the buildplate already has some deep marks and at least 3D-Printing seems to be impossible.

2 Likes

Ok, I think I found the issue.

The calibration is done using a capacitive or inductive distance sensor. These sensors do detect a surface without touching it. The sensor itself is on the right side behind the nozzle on the printhead. On the back of the printhead is a screw in a longer slot. This screw is connected to the distance sensor and allows to move it up or down.

I’ve moved the sensor down almost 2mm using and tightened the screw again. Now the calibration does no longer touch the bed. It stops when the nozzle is about 1mm above the bed.

So, you should probably check the position of the distance sensor bevor doing the first calibration. Make sure it is a tiny little bit higher than the nozzle so it does not touch the model you’re printing. My sensor is now about 1.5mm higher than the nozzle.

8 Likes

I had it dig into my build surface as well. I’ll have to check this on mine.

Had the same issue on the back part of the calibration, it just kept going down until I shut it off and turned it back on, seemed to have calibrated fine that time. I also have a steel band on one of the axis that is very loose kind of a bummer and definitely annoying sound on it when printing right now from it vibrating.

Looks like it helped for one single print only :frowning:

As the first layer was a little bit too low I tried to calibrate again and it pushed the nozzle into the buildplate again. So this issue is not solved for me.

Update: The sensor is now at it’s lowest possible point. Calibration did run ok. I wonder if it works more than once this time.

Definitely keep us updated!

A350 here, and the same problem. Calibration point 5 is by far the worst, but 6 and 7 seem to do it as well (not as bad as 5). Seems to be somewhat random to me.

I have noticed if there is any filament on the tip of the nozzle, it seems to bury in the plate at point 5 and cause a calibration failure.

Will try to move the sensor and see if it improves, but it seems more random than a sensor adjustment to me. Something in the calibration programming about point 5 is messed up, otherwise I would expect it to be at others points as well.

And like you, I now have a brand new build plate with a bunch of divots in it at point 5!

One print complete then again failure. I would like to know what the return policy is on these, received on Jan. 16 am ready to return until snapmaker can figure out stuff, can some one point me to the return policy on defective goods, calibration was ok once then failed the last two times. Have submitted info to support at whatever the official email is to make sure and have a case logged with them. Is it the Chinese new years right now is that the cause of the lack of responses from them?

A350 here and I’ll be honest, I’m very irked by Snapmaker 2.0. It doesn’t work at all in fact way worse than 1.0. Calibration dented my build plate really badly and like the rest here, have a hole there now. After calibrating it tries to print the air at max z and the linear modules don’t allow the top bar to be level at the top so it’s tilted to one side. Should of just stuck with my 1.0 since it still works fine :sweat_smile:

1 Like

Well that’s a big yikes from me. I have ordered the A350 and it will ship out in June. Hopefully they make some improvements before then.

I have no issues with my linear modules being level. Did you manually align them before attaching anything to them?

1 Like

Yep I did! However when I pulled them up to the top as per the guide i noticed that the right one always bounces a bit back down. To be honest just seems like their both just messed up anyway considering it thinks that the top of the Z axis is 0

DOuble check that your Z and Y axis cables are in the correct connections. What you are describing sounds like you got them reversed at the splitter box. Meaning sounds like your Z cable is connected to the splitter box attached to the Y axis, and Y cable connected to the Z splitter box. With as many cables as the A350 has right there in one small spot, it’s easy to get them crossed.

1 Like

I’ve gone over this 4x now actually, was 3 but just in case I checked it again just nowh, funny thing is Y seems fine honestly, it’s Z and X that seem crossed, not that I could mess those up given they have labels on the controller, but I checked anyway to be 100%, I’ve even unplugged and re-plugged everything in again. Unless the splitter boxes themselves actually have a pairing and i reversed the placement everything is correct I can see.

Oof, that is odd then. I know I had the same issue for the first bit, but I traced every cable and found I likely had them reversed. Not sure what to offer not then.

It’s pretty messed up, i’ve got a thread going here Snapmaker has the wrong positioning

But so far really bad first impression, the snapmaker 1 worked amazingly out of box and I was setup and printing within a few hours of it being put together, this one I’ve spent 5 hours debugging already and nothing.

1 Like

You may have your base plate attached upside down, mine stopped on 5 and i found that the little metal nibs were supposed to be on the bottom instead of the top. I reversed it and now it still pushes down to far at 5, 6 and 7 but it completes every time now

I had my baseplate upside down, Though fixing that only fixed the calibration issue for one print.
Then it started pushing HARD down into the plate at the back again. You could hear the steppers running FAR longer than they did for the front and middle calibration points.
After several calibrations, and leaving the machine turned off for a couple of days - it started working again.
Not sure for how long it will work though…

I had the same, few times it worked normally.
But one time it hit the plate hard and i had a small hole now :frowning:

But i think it‘s not the normal calibration routine, it‘s that one directly before printing.

image

I had the same problem as you.