Calibration pushing deep into buildplate

Do you still have the same issue?

Did you try lowering the proximity sensor? It’s supposed to be 1.5mm above the print probe.

No, flipping the baseplate fixed it for a print or 2, then it came back, then it went away again after several power cycles/calibrations and sitting for a couple of days.

1 Like

Same issue here and after lowering the sensor it still failed. I did notice though the back probes 5-7 are digging into the build plate because the conductive sensor is half on the build plate and half off. I am going to offset the magnet build surface to see if it helps but I believe the autoleveling spot needs to be 10 mm forward. Don’t know if we can change that.

So I wanted to make a post about this but they wouldn’t let me. So hopefully people find this solution.

So I have been having autoleveling calibration issues like many others where the head digs into the build plate ruining it. A few people have mentioned lowering the sensor to about 1mm above the nozzle but in testing and observation that is definitely not the fix or issue unless your sensor was placed way to high and is digging into auto leveling points 1-4. If you are not digging into your first four points then your sensor is working properly and moving it is just increasing the chance of it hitting your print. I will explain the issue for me why the back points 5-7 are digging into the build plate.

First I am going to mention how to tell immediately if you are going to dig into the back 3 points before even getting to them. Keep in mind this assumes your magnet plate is perfectly aligned with where it needs to be, which is what I do due to my OCD:). Pay attention to the first calibration point, if your nozzle is slightly to the left of the build plate and not above it, you will successfully calibrate. If it is above the build plate then you will dig into the print bed. Why? Well lets get into that.

For some reason the machine seems to loose its calibration start point sometimes and it begins in the wrong spot. When the machine does this it will calibrate the first 4 points fine because the probe is above the build plate but when it moves to the 5th point and your build plate is perfectly aligned you should notice that the sensor is half way off the plate which means it can not get a good reading and continues to push down until it fails. If you look at your print indention made on your plate they should fall close to the 340 line. When the correct calibration start position is happening the nozzle will actually be closer to the 320 line meaning the sensor is well above the build plate.

So how do we fix this issue?
Potential Easy Fix: One easy way I suspect but haven’t tried yet is if you offset your build plate to hang off the back by 20mm it MIGHT work. That is if the plate is enough for the sensor to detect. The correct fix for now is a little more work.

Sure Fire Fix: Inside of Luban connect to your printer. Home your print head and then in the Console type “M502” and press enter. Then after you see the “ok” type “M500” and press enter. This should essentially wipe its settings for you to re-home and re-calibrate the printer. Disconnect from luban and on your printer HOME it. Then immediately perform a autolevel calibration and pay attention to the first point. The nozzle should now be hanging slightly off the build plate to the left but the sensor will be well above the build plate. If it is in this position you should finish the process normally without any bed damage and can set the Z Offset at the end. Then it is happy printing until it gets off again!

Hope some of you find this information helpful and it prevents you from moving your sensor unnecessarily or prevents some bed damage. I am saddened to have holes in a brand new build plate but this is the part of being an early adopter that we should expect. Happy printing guys!

2 Likes

Thank you for the post DaneC020. I have the calibration issue as well. My dig points are between the 270 and 320 marks though. I have printed multiple items in the week i have had the A350 with good success.

The last 2 days I have had to auto calibration 2 or 3 times before before each print and then it fails on the quick calibration when you try and print. One Auto Calibration just dragged the plate over to the number 6 spot. After leaving it off overnight, the auto calibration worked along with the quick calibration before the print started and I had a successful print. I added another job and walked away for a bit while the plate heated up. I came back to a gouge in my plate and the print head stuck in the plate.

I will try your calibration recommendation for the auto calibration.

The Sure Fire Fix worked. It calibrates in a different spot now for the first 3 and number 7 and 8. I am now printing again although I have to make sure I don’t use the left side of my plate because of the gouge. It is nice not having to watching it push down in the back so hard during calibration.

Thanks again DaneC020

Well, it worked for one print. It went back to poking a hole again. Tried the process again and it doesn’t work. I will have to keep searching. :frowning:

There must be another reason. The inductive sensor at the head detects (magnetic?) metal. I thought the whole removable printing bed is magnetic.

Why it correctly detects four points and especially point 5 isn’t working reliable?

I‘m not sure, but i remember the standard calibration works without problems, it’s only the fast calibration direct before printing which fails (hits deeply)?

Just turn off the quick calibration before the print. Try it and see if it solves your issue for now.

You mean completely deactivating auto calibration, so set the offset for each of the 9 points?

If i do this, the auto cali directly before printing is off, or i have to do it manually for each point and every new print?

I have that turned off on mine, did a manual calibration of all 9 points and then turned off the before print quick calibration.

Where i can disable the before print calibration?

For me (on original firmware) its home screen swipe left, experiment, preferences and then turn off quick calibration.

1 Like

Can you post a screenshot?
After swiping left, i only have

  • Files
  • Control
  • Calibration
  • Settings

Touchscreen: V1.5.2.1
Controller FW: 1.6.0.0

And i thought, before the update it was exactly the same.

It’s in the settings screen.

Here is mine. No updates of any kind have been done since I took it out of the box.

I tried again with auto calibration… now snapmaker totally ruined the printing bed :frowning:

Sorry, but this functionality isn’t working correclty!
I correctly set z-offset, than the auto calibration directly before prints starts and after heating bed total Desaster!

I‘m very angry and frustrated

Good evening all.

I have had the same issue and been following this thread. The difference is I have 2 snapmaker 2’s. 1 has this problem, and the other one is printing just fine. I have been playing with all the settings, doing all of the suggestions and testing different leveling techniques posted here and on facebook. I get the same results. I have come to the conclusion that it is some sort of defect in the sensor and/or bad memory where the data is stored after we calibrate. I don’t know enough about the sensor or electronics to properly diagnose. But trust me, I have done everything under the sun to try to fix this. I believe the best option at this point will be to request a warranty repair. I feel that there are enough of us having this problem that there is something defective, and that they will have to do either a recall or repair. @Rainie

1 Like

Droneon- Could you please post your firmware version screenshot or the text of it. My original (as shipped) FW doesn’t display any of the experimental options.

Many Thanks!