Bug in the Luban software when processing svg files?

When I try to “Process” an svg file for laser cutting, sometimes the post-processed picture comes out different than the original. Meaning that the machine isn’t cutting what I see on the original picture. Is this a bug or am I not using the software properly?

Using the latest Luban software.

Not enough details to help you.
Need more info what you mean by it comes out different?
Is it leaving out parts?
What settings are you trying to use?
Screenshots and original file helps.

Here’s the screenshot:

Loading in the original svg file (generated from Illustrator):

Then, hit the “Process” button, this came out

The finished product will look at the 2nd picture, but I want to cut the shape from the first picture…


Upload your file please, then we could forward this to the right person. @parachvte

1 Like

Please see attached for the SVG file I’m trying to process.


Strange. Doing the same thing in my Luban. Tried opening in inkscape and it looked fine.
Tried saving it again and changing object to paths and still did same thing.
Tried adding points close on both sides of point that was disappearing in Luban and it seems to be working fine.
I don’t know if it’s a Luban problem or svg problem. Luban is plenty buggy but have had plenty of weird quirks with svg files too.
Here’s my fix:


1 Like

Appreciate your help! I guess I need to add more points besides the disappearing points to work around this problem / bug? I’m using Illustrator if that makes a difference…

Don’t know illustrator well enough anymore to say.
I think you used to be able to select how a point reacted -whether it was a fixed point or a curve (bezier?) or something like that. Maybe there’s something with how that one point is set? Didn’t show up in inkscape as anything I could change.

@iwannasee Which version of Luban? Here’s what I see with 3.9.0 and your example.svg

I wonder if this was a bug that was fixed already. There are a couple SVG fixes listed in the changelog. See here: Snapmaker Luban Downloads and Updates

Just mention that because if you’re were looking for the latest version on luban.xyz up until a few days ago it had 3.8.0.

We have run into closed path issues in Illustrator before that result in nearly identical problems to what you were having, but I looked in Illustrator at your file and it looks fine.

Indeed I was using 3.8.0 Luban, just upgraded to 3.9.0. That issue appears to be fixed for most part but still some points are messed up when I tried a more complicated svg file.

My workaround now is: load the svg in Inkscape, save the exact same file back to the svg. And somehow that works and no more issues with the processing (this was in both 3.8.0 and 3.9.0).

1 Like