Brand New A350 with broken linear module

Well, it appears I can add myself to the growing number of people who have received A350 with faulty Linear Modules. As the bed moves forward I can hear an audible clunk and the bed seems to jerk at the same time. The same happens when I manually jog the bed towards the rear. I guess I can try to isolate which Y-axis module is broken by unplugging one and moving the bed and do the same with the other module. Anyone else have the exact same issue. If so, were you able to fix it by taking the module apart or should I just contact Snapmaker support. With so many others experiencing these issues, there is obviously a design and or quality control problem with these Linear Modules. I am kind of bummed after waiting 13 months for it to arrive.

Tough break, Mark! I guess that Snapmaker know about this particular fault. Whether they have successfully fixed it is another matter. It is clearly a QA issue and may not be rapidly resolved. Definitely contact support before you try and disassemble your module. That action may well invalidate your warranty. As the item was DOA when you got your machine, you are entitled to warranty care, which should offer you a refund or a new module.

Check with support as to the availability of non faulty linear modules and the time frame. If you are not satisfied, request a refund and look for a machine that is completely fettled and has a better track record and reputation. I sincerely hope you get the issue resolved soon.

Edit: The issue is with the linear module:

Thanks jepho for your reply. Well I think I have sorted out the problem with the clunk and jerk on one of the Y-axis modules. I did some trouble shooting by disconnecting each of the modules separately to see how it performed with only one Y-axis module. When tested separately, they both worked fine. The problem was only when both Y-axis modules were connected. I observed which module I thought was causing the issue and swapped it with the X-axis module. This seemed to fix the problem as all three axis now move smoothly. I guess for some reason the two modules I chose to use for the Y-axis didn’t want to work together. Obviously, there is an issue with what is now my X-axis but at least I can use the machine for now. Hopefully Snapmaker will reach out to those who may have defective modules and offer a solution. I’m not sure why I would receive a reply stating that my order has been delayed.

You are welcome, Mark. It seems that there was a QA issue with some of the outsourced modules. I believe that you will qualify for a replacement module(s) and get a $50 discount on the upcoming rotary module by way of thanks for your patience. Good that you managed to pin down a solution and hopefully it will be a permanent fix. I saw somewhere (cannot remember where I read it though) that a couple of overvoltage diodes appear to be missing from the faulty modules.

wait one… I think it was @Toxic. Ok found it.

Circuit diagram linear module? or why my linear module is broken