Blank Touchscreen

I’ve been using my Snapmaker for a week, and it’s worked well for the prints I’ve tried. During the last one, the touchscreen went blank about 1 hr into a 1.5 hr print. It didn’t show “Tap screen to activate” like it usually does, it was just blank, with a small glow (reddish-black) showing it was powered but otherwise blank (no white screen, nothing displayed). Tapping did nothing. The print finished fine. I cycled power with no change. I tried with or without the USB drive plugged in - no change. I downloaded the latest firmware “Snapmaker-GD32Base-2.4” and put it on the USB drive and followed the firmware update instructions. The LED blinks occurred as expected (slow, then off, then fast) and so it seems like the latest firmware is installed. But the touch screen is still blank. There is a general glow showing it has power, but no image, no white screen like some of the forum posts, just the general dark-reddish glow, so no display, just power. I tried unplugging the touchscreen and plugging it back in again to make sure it’s plugged all the way in. No change.

I’ve emailed and am waiting for a reply.

What can I do without the touchscreen? Can I use the computer connection to do everything the touch screen does? I haven’t tried yet. Reading the manual and forum posts, I gather I can run prints with the computer connection. Can I level the bed and/or change the filament and/or jog the stages without the touchscreen? I see some manual commands over the serial connection in some posts. Is there a list compiled somewhere and do they include the bed leveling functions? My bed seems to be staying level so it’s probably not a big deal, so probably just figuring out how to jog the stages + change the filament is all I need while waiting for technical support and possible touchscreen replacement.

I have connected a laptop and have explored the available functions in the newest SnapMakerJS software. I don’t see a way to level the bed or change the filament. Is that possible with some console commands? I tried to search the forum posts but haven’t found anything relevant yet, nor a summary of console commands. I know some g-code from a past career in micromachining, but don’t know how the leveling is saved. At some point, a wiki might be helpful to crowd-source some of the documentation and details.

As for my touchscreen, I just realized that the touch is still working. The only thing not working is the display. So I used the printed manual to figure out where the buttons are and have leveled the bed again (after resetting it by accident when I first found out the touch was still working with no display).

So I have no display - nothing, from startup to whatever screen I navigate using my blind touch usage. So I guess this is usable until I hear from SnapMaker support. Of course, I’ll use the computer for as much as possible and only the touchscreen for leveling and changing filament.

I left the snapmaker 1 on over night after it finished a print, and now the touch screen is blank(black screen with only the backlight on). No disconnecting/reconnecting of the cable works and pulling power to the unit and restarting also does not work. Suggestions? @Rainie any help?? Just backed a Snapmaker 2 but really need my 1 to keep working until the 2 arrives.

Sld. Tengo una impresora snapmaker también el display esta totalmente en negro, no se ve nada., pero si si reacciona cuando se toca sobre la pantalla.
¿Como se puede resolver este problema?
La impresora la trabajo directamente desde la pc mediante el cable usb. Como no puedo ver la pantalla la calibraciones de la impresora las tengo que realizar a mano.

I thought I’d put this out there.
I have an original Snapmaker which suddenly stopped showing a display.
I think the touchscreen was still functional, but I couldn’t tell what I was doing,
Since the machine was out of warranty and I didn’t want to spend $$ for another I decided to take it apart.
I carefully pulled the glass screen off (go slowly and the adhesive will release) and things looked ok.
Then I carefully released (the little metal clips) the circuit board and unfolded the assembly.
Although the parts looked ok along the crease, one of the capacitors measured as a short.
I removed that part and the display now works (I don’t know what that capacitor does, so we’ll see how functional it is, but I expect it to be OK).

very cool :smiley:

it must be the broken/fixed switch

curious to what the thing will do differently without it :joy:

hi ,could you solve the problem ,because now i have exactly the same problem.

hi there
I have the same problem ,
i ended up opening the screen since its out of warranty
which capacitor did you remove

That was quite a while ago.

I’m pretty sure I measured the capacitor first and was able to determine that its resistance was very low.

I think it was one of the ones near the flex connection.

There might be a couple there, so maybe try and measure them first.

Good luck!


thx for the info , will do that and see how it goes