Bed calibration crashes during initialization II

Hello, yesterday I’ve unboxed and assembled my new A250 for 3D printing. Nice parts, well packed, organized and good looking.
Successful initialization, BUT! When i try to start bed calibration, the head goes up, calibrates for the end point, then to the left, then down. Y-move but shortly. (probably not smooth enough?).The head comes down and runs down to the bed, then it stays there or moves fortuitously with motors “ON” (humming). On one try X-movement made a bad scratch into the building plate with the print nozzle.
As I haven’t found any procedure to skip the bed calibration I cannot even try the new firmware.

New try: In “origin set” mode, z- and x-axis correctly search for a reference position, y-axis motors just move a bit or run to the rear end position without smooth end stop - humming
Cables are correctly connected.I also interchanged the distribution boxes - no effect.
M520 and M500 commands also didn’t change the situation significantly.

Pls help!
Peter

I have fed a similar topic into the Snapmaker 2 forum before, but it didn’t become visible

Hey @ipeco85

1st. Check the position of your bed calibration switch. - look at the thread of “official response print head gauge”
2nd. You could manually switch this inductive switch at every calibration point with a screwdriver or something else, at a higher Z-position to not crash the nozzle to the bed.
3d. Firmware update

Hope this helps!

Edit: maybe do point 2 before 1.

Hello xchrisd,
thanks for the fast response, I’ll try tomorrow. Do you also have an idea how to update the firmware BEFORE the “bed calibration” request. I always needed to switch-off power to prevent more serious damage of any component, so I never got so far to having access to the menu on the touchscreen …
Thanks a lot
Peter

With the step 2 you should be able to the calibration without harming the bed. It‘s not real calibrated for printing but you can finish the startup wizzard.

Then do firmware upgrade and check the position of the leveling sensor. After that and even after every firmware upgrade you should do a calibration.

If then the head still wants to go straight to the bed, remember point 2 and stop it with something like a screwdriver or everything else on metal which is not to big to harm anything…:wink:

If you don’t trust point 2 try with the magnetic bed in the hand and during downwards hold it to the nosle and sensor and the movement should stop immediately.

Hope this helps!

1 Like

Hi @ipeco85 Here is Edwin from Snapmaker Team.

1 Like

Thank you all for your ideas!
I mounted the CNC head to overcome the printer menu and then could update from 1.5.x firmware.
But the issue with the bad response of the Y-motors stayed as before.
Using the CNC positioning controls I tested the motor drives and found an issue in the Y-line: controls worked inverse ???
At the end I found a very curious solution I can’t understand but it works:
I interchanged the Y and Z controller cables at BOTH ends and now the motors move correctly and also bed calibration runs smoothly. So the cable designation on the controller is X-Z-Y instead of X-Y-Z, but the motors are connected in the correct X-Y-Z order !
Previously I re-connected the cables several times in the right order and I’m sure to have them put-in completely. With about 40 years electronic experience, I’m pretty sure to to haven’t made any failure.
God knows …
But happily it works now. Now I have to calm down a bit and then I’m looking forward to get the whole unit working - but not today :wink:

Best
Peter

2 Likes