Axis Movement Issues

I just setup my brand new unit and when I attempted to run my 1st print but the head bound slightly and moved the magnetic build sheet. No big deal as I stopped it. Now none of the axis will move. Powering it off, I am able to move all 3 axis freely. Upon powering it up and attempting to home, nothing happens. I’ve tried the bed calibration as well which returns an error “something went wrong”. The steppers engage as the 3 axis cannot be moved but it is not actually moving with onscreen controls. The controller is responding as the enclosure fans, lights and air purifier all respond to controls.

I backreved the firmware to 12 and 13 and the Z axis will move just a bit when hitting home, but nothing else will move. 14, nothing happens. I’ve 502/500ed the system as well with no gain. I paid a lot of money with all the accessories for a boat anchor after 1 misprint.

First thing to do is check the cables from the controller to the axes. Ideally, you should unplug and replug them at both ends, just to make sure nothing’s worked loose.

First thing to do is to make sure it’s assembled properly. 90% time when I read something like your situation is the Y rails aren’t in their base recess.

I’ve tried all the plugging/replugging etc. I unplugged everything except power and the 3 axis. It was going great just kept trying to drive the Y back beyond where it should because the sheet was off of the base because I had a bad Z calibration. Stopping the Job and trying to home it shouldn’t have broke it. I would assume ONE of the axis would move if something wasn’t 100% seated but I get no movement when using the controller. it’ moves quite freely with the steppers off.

Even the extruder heats up, but will not extrude/retract filament. Basically, anything involving the movement of the steppers does not work.

Double check that the linear modules are in the right locations. The Z axises module(s) have the 8mm lead label, and the X and Y have the 20mm label. The controller refuses to move if the modules are installed in the wrong locations.

If the print head is pushing into the build plate, check the proximity sensor.

Huh, all 5 of my linear modules are exactly the same and interchangeable.

None of the cables were bothered between the time I stopped the job and tried to rehome it (prior to power it off or doing anything else). That did give me an idea. I tried leaving only the X plugged in, but no joy there either. door sensor is off so I haven’t the most remote idea what is going on.

I didn’t know this had a proximity sensor which makes me wonder why it pushed into the build plate.

I was under the impression that all new snapmakers got the differentiated rails. The store makes it sound like there should be a difference. vs

IIRC, the 20mm modules give you more rigidity during CNC or something?

To be fair, OP never said he had a 350. I guess we all make assumptions based on our own experiences. My 250 are all identical, and that’s the first thing Snapmaker support always seems to make you do… swap modules around. :stuck_out_tongue_winking_eye:.

It is an A350 with enclosure, air filter etc. The fact that not even the extruders stepper will move is highly odd.

Do they move (freely) by hand with the power off?

When did you buy? I think @clewis is assuming that @kc8iqw is a pretty new purchaser, and the newer machines more than likely have the ‘revised’ rail plan.

Like yours, mine (on my A250, Kickstarter generation) are exactly the same currently and don’t have 8mm vs. 20mm labeling. (I did buy a set of the upgrade rails with a discount offer but haven’t bothered swapping them in, waiting for a failure/reason with my first set to go to the effort…)

I too bought backup rails, not the new ones because those can’t be intermixed (and they’re the same as my original rails for all axis).

The door sensor even active shouldn’t prevent any of the axes moving. You said it started to print out fine a first time, which seems like you had everything electrical plugged in right (flipping the cables in the connection points is possible, and would make magic smoke go poof, keep that in mind for future).

The z height sensor is present but can be misaligned or (in rare circumstances) internally unplugged. You can perhaps test that holding a piece of something metal like a ruler right up to it, see if you see a tiny LED on the back face of the printhead near the bottom light up. Adjusting it is pretty easy and can be done with almost no effort, just want it to be a tiny bit above the actual nozzle tip and definitely not below it. Guidance on the sensor and other Z-height issues is here:

As far as your REAL problem now, none of the steppers (even extruder) working, that sure sounds like something done got burnt out in one or more drivers somehow, but we’ll hope not. Try powering the whole machine down again for a while, unplug the PSU even, then starting up again. (If you’ve burned firmware into it a few different times trying to diagnose though I bet you’ve already tried this more or less).

Ah, I specifically bought the “T” rails with a 50% off coupon offer. Heh, now you have me wanting to open the box and check out of paranoia of what I ended up with…{scurries off}. But this is a sideshow to trying to help out @kc8iqw right now.

EDIT - check completed. Box has 3 20mm labeled, 2 8mm labeled rail packages in it. Whew.

With the “it worked for a little bit”, I’m wondering if the data cables got plugged in the wrong way, and @kc8iqw let the magic smoke out of the controller.

I suppose something could have gotten burned out. After the failed print, I tried to home it but it Y was trying to move but not and X and Z seemed fine. I powered it down to move Y back to center and powered it back up. Ever since nothing moves

It moves freely w/ power off. Power on engages the steppers (both audible and the fact you can’t move any axis by hand). I’ve built a 3D printer before, just wanted this since my creation has a very odd and specific defect that has confused the RepRap experts :slight_smile:.

Worked till I stopped the print and powered it off to move Y back to center so it could home correctly.

Yeah I’m out of ideas if full power off for a while doesn’t help, all connections are good. You could still have a misassembly (rail position in the base grooves) but that does not explain it not even trying to home. Its like the steppers are powered (locking) but not getting any data. (EDIT - although I did think again, if it’s waiting for a homing to be complete, then makes sense it wouldn’t jog even for you, but other commands like bed and extruder heating might work…doesn’t necessarily explain that extruder can’t even push filament though…)

I think homing is Z (x rail vertical), then X (head on rail), then Y (table). You could unplug X and Y, see if you see the Z action. Then swap out the Z splitter for the Y splitter, repeat trying Z only. (Or if the first test didn’t work, try with the 2nd splitter). That might rule out one or the other of them.

Beyond that I’m afraid you’re at the stage of direct customer not user forum support…

@rtrski Well, sir. I decided to unplug it for the entire night and was going to swap X and Y around but when I powered it up to check proximity sensor, it decided to work. All axis are moving now. Strange beast this thing is… Thanks for all your help everyone that replied, especially whoever mentioned unplugging it for a long time.

1 Like