Anyone add TL Smoother to their servo motors (SM1)?

I have narrowed it down to Moire issues with either my extruder or x/y axis. Has anyone added TL Smoother to their servo motors?

https://www.amazon.com/BIQU-TL-Smoother-Elimination-Clipping-Controller/dp/B0727QT316

I have tried everything else and this is the last resort. I can change the pattern of the Moire by rotating the part but I think this is the servo motors doing this.

Do you know what type of stepping controller is built into the machine?
Here is a little information about tl smoothers

The SM1 has A4988 Stepper controllers and will improve with TL Smoother.
Already know their value/improvement.

I’m asking if anyone here has attempted it yet or am I the first.

I have the stepper pinout for the RJ25… Just want to know if someone has tried.

I haven’t seen anything like that on any of my prints. I’ve used Snapmaker3D, SnapmakerJS, and Cura to slice, with similar print qualities. I generally print using the “High Quality” setting (copied to Cura), but haven’t had seen anything like that the few times I’ve used “Fast Print”.

What slicer and settings are you using? I see from your posting history that you’re familiar with Cura, customized your print settings, and asked how fast you can push the extruder. I wonder if you’ll have the same results using Luban and a slower stock print setting.

I use Prusa, Cura, Simplify3D… but no longer use SnapmakerJS. This problem is really bad in VASE mode and single walls (as in the picture). Once I do Inside to Outside walls it really does not show much. I have even re-compiled my projects in Fusion360 to use lower and higher quality to see if triangle count changes the effect… Nothing

I adjusted Jerk/Acceleration, all Calibrations are spot on (Steps, Extrusion Mult/Rate) and dimensionally items are spot on… Don’t really push my printer much past 75% of recommended speeds. Also tried linear advanced (i’m a metal CNC Programmer so I research and try every available options). I currently use Octoprint to feed my machine (also tried USB Stick and USB/PC Connection).

I have turned on/off one item at a time for just about everything and done test runs to see what happens. I can shrink the effect but it’s still there.

So the only thing I have not tried yet… is a TL Smoother.

Now I do have one item to try tonight which is rounding up my E-Steps to an even number and remove the decimals to see if this is an additive problem where it adds up and then rounds up one skipping a step.

I think it’s worth a test using SnapJS / Luban just to see if it’s software or hardware. If you can get a smooth print using the defaults, then you know that you can fix the issue without a hardware modification.

Which isn’t to say that the smoothers won’t be a useful upgrade. I’m not advanced enough to weight in on that. I just know that when I’m debugging something complex, going back to stupid-simple can help me figure out if/how/why I’m shooting myself in the foot. :smiley:

I never had this print picture even with 100mm/s at square parts with sm1.
(tried fast printing at the beginning of my 3d printing experience)

I would say you have a defective machine,- if you are under warranty you should tell the support…

TL Smoothers are a good solution, saw the article of ALL3DP in the newsletter.- Very interesting but i thought there is surely a tl smoother built in the sm1, because of the fine print picture…

May you upload your gcode to double check?

not defective as i print multi-wall items and they are smooth and do not show this. This only happen on single wall or vase mode prints


Here is a close up of a cylinder tool (O’Ring Installation Tool/Bullet) and the surface is clean and no Moire. Did have a couple of drag marks but very smooth.

Watched a You-Tube on the A4988 servo chip and it does in fact studder ever so slightly when moving.


Here is the video of the issue.
1 Like

I tried to print as vase and the problem also happened. But it looks different from the picture you posted. I guess modify settings in the software can help in this issue.

Maybe you can post the g-code and settings for printing here so that I can make a try on it.