10W Laser No Longer Cutting After Upg to 1.18

AT350 w/ 10W laser and quick swap kit

Last week cutting 2mm basswood fine, but the laser was leaving fine lines while traveling.

Read another post that suggested firmware upgrade. Fine, upgraded to v1.18. Now the laser will not cut, mark, anything. It does a thickness calibration fine. The camera calibration has never worked right. I regenerated the gcode and, while it will go through the motions of the cutting job, it makes absolutely no marks on the work piece. I am using Auto Focus - and it is measuring the piece correctly.

Firmware: Snapmaker2_v1.28.0_20231025
Touchscreen: v1.18.5
Controller: v4.6.2

Also of note, I use the Snapmaker Enclosure, but my door detection has never worked. Doors are shut, but jobs will not start unless I turn off door detection manually. Kinda annoying, but didn’t seem to be a problem as of last week.

Thoughts?

As far as I understand 1.18 introduces a more thorough policy regarding enforcing closed door. So if your door sensor does not work, most likely this blocks your laser. You either need to repair your door sensor (should not be too complicated, in most cases its problems with the magnet alignment), or unplug the enclosure. Or downgrade firmware, obviously.

Perhaps this helps you to repair your sensor: Warning: Security issue - Enclosure door detection not checked at start/not fail safe - #3 by Hauke

1 Like

@Hauke - solid advice! That appears to have been the issue - the laser powering way down due to the doors being “open”.

Your other post on the sensor module was enlightening as well. I had no idea there were LEDs inside that module. My door issue was magnet alignment and the LEDs made short work of getting that resolved.

I’m back to cutting AND the travel markings are gone! Thanks very much for the quick reply and helpful advice!