Z linear module not working correctly

After my first short print (1hour 15 minutes ) on my recently arrived snapmaker 2 the z linear module refuses to descend more than half way down to the heated bed, it moves in a series of jumps especially on the right hand side and then makes a high pitched grinding sounds Turning it off and on again only repeats the process I have reported this support 3 days ago but have no response yet .

Sounds like one of your controllers inside the linear module has died and is no longer communicating with the main controller.

I think that would explain both it only moving really with one side, and also only moving halfway as it would think it’s a a150 model and not try and move more than about halfway.

unfortunately I think you’re on the right track trying to get support to replace it

Thanks for the info, it is a shock to me that a machine I have waited 11 month to receive should only work for an hour .Hopefully the module will be replaced quickly but has anybody experienced this machine working without fault for an extended period of time months .I ask this to try and understand whether all the modules should be changed with modules which are checked as working or should I believe that I am just unlucky

Hard to say - many of the 7000+ users are not posting on this forum.

Many of the people on here have had to wait sometime but eventually a new module will be sent by support. It’s a test of patience for sure, very frustrating.

Support will likely ask you to check for thermal pads using these instructions:

I’d recommend waiting for support to ask you to check that as they have been inconsistent in honoring/denying warranties.

From their warranty docs here: https://support.snapmaker.com/hc/en-us/articles/360051069934-Snapmaker-s-Limited-Warranty

The following actions will void this warranty
   Disassemble or repair without authorization by Snapmaker or the Distributor.

But then they also post official instructions on how to check the thermal pads. But then they gave someone else on the forum a hard time, arguing they didn’t authorize them to disassemble it to check.

@Edwin @staff - will there be any clarification on if users experiencing issues are allowed to perform the checks on the Snapmaker website without voiding their warranties?

I’ve had my A350 since mid-July.
Since then up until the last couple weeks I’ve pretty much been printing, cnc or laser non-stop 24/7. Always had a new project waiting for the other to finish. Last couple weeks I’ve slowed down and been running 12-14 hours a day.
Other than having to adjust some play in x-axis bracket (probably pushing too hard through some tough oak causing chatter) and my controller cord being sliced partially by a sharp edge on the holder (sent photos and SM sent a replacement within 2 weeks) have had no issues. Only other problem was caused by me (and not having an emergency stop on the controller) Toolhead cable got caught on clamps and tore out. Bought replacement cable and got that in a couple weeks (fortunately old one still worked with some duct tape to keep it in).
Really hoping I’m not jinxing myself now. :wink:


1 Like

Thanks again I appreciate the information I was not expecting to have to be an engineer but cest la vie

Tried to go to the linked page, keeps saying I am not authorized to view. Did Snapmaker remove the page?

Yes, that page was deleted. You need to contact support now, there are no public instructions for checking the thermal pads