Z axis does not work

I ordered in September and by the end of December I was able to receive the product.
However, because of my schedule, I was able to assemble the product today on January 17, 2021.
The product was explained so kindly that it was easy to assemble.
However, I felt strange while operating the product.
When the product was auto-leveling, a lot of time passed, and the X and Y axes were working, but the Z axis did not respond at all.

Looking back at the assembly of the product, there was nothing wrong with it.

So, I searched and found an article on the official homepage asking to test by swapping the Y-axis and Z-axis.

Then the Z axis worked, but the Y axis did not.

I have inquired about a problem with the product according to the procedure.

Has anyone ever encountered the same problem as me?

I wonder if anyone has solved this problem on their own

Sounds like the problem is either with the controller or the cable. Swap a known good cable to the axis that doesn’t work to find out which it is then support will have to fix. Make sure you switch off when connecting/disconnecting anything.

The results came out as per your advice~ Fortunately, the company solved the problem by sending the controller back