Z-Axis falling down?


#21

My printer keeps resetting and won’t complete the print. Mine also slow falls when powered down. Could this be causing a system reset while printing for some reason?


#22

Hi @Carcharoth and others

Doug the newbie here. It is most difficult to provide any advice or suggestions when not information is provided.

What software are you using and its version; are you using the latest Firmware on Snapmaker? What PC operating are you using? how is it connected to the Snapmaker. The more information you can provide would be most helpful.

Take care

Doug


#23

Thanks Doug, I should have been more clear. I will be in the future. For now though it’s looking like a printer issue as i have made around 20 of these prints. I just switched to port 4 from a post I read on here, and put the system to home before engaging the g code file. Tbh it’s the last test for awhile unfortunately. I’m thinking this is a quantum machine lol. I’ve heard it quit but only caught the reset once with my eyeballs. If this fails My plan is to send off a detailed report to snapmaker. Pretty new to this hobby so not up on all the lingo so that will be a quest of its own.

I did read and agree with your earlier post about making a group norm to add simple specific details. Having a forum Time stamp and hoping for a fluke quick fix was my main goal.


#24

Hi @Carcharoth

Thank you fro the response, much appreciated. Many of us are new to this great new addictive technology and are learning all the time… there is a lot to learn.

Keep having fun.

Doug


#25

Hah. I know I posted, long ago, that I didn’t have this problem… but I absolutely have this problem… and have had it. I stopped printing for about 10 months because I was getting frustrated with it. I’d print a long job, leave for a bit and come back to find my nozzle burried in my freshly finished project… damaging the project, and clogging the nozzle.

I’ll try the screw adjustment…


#26

Hi!

Sorry for reviving an old topic, but I my question is close to the original one, though regarding the Z-axis extension, not the original linear module.

Is it OK if Z-axis immediately slides down when I turn the power off? Here is the video: https://youtu.be/ou7P8Ub2g2w

It never happens when the power is on so it doesn’t affect printing, everything works great. It stays up after the printing, but when I click the power switch the slider immediately goes down under the weight of the X-module and the printing head, no additional force applied. I’ve checked the screws @Rainie mentioned and they are tight. It also never happened with the original “short” module.

Not a big deal since it happens only in off mode, but I’m a little bit worried if it can be a symptom of some possible future problems.


#27

The linear module is installed too loose (internally) but it’s ok, just keep your tool head intact.


#28

Thank you. With “intact” you mean that I should check that the printing head doesn’t hit the table when falling down? It doesn’t, it stops before that.


#29

I still have the same problem as well, though not as extreme as you demonstrate. Perhaps tightening it down will help, as Parachvte suggested. I happened to me shortly after purchase, and even with the extended Z-Axis upgrade. I have put some gcode in my ending script (in simplify3D, not sure if we can do this in snapmakerjs or not) that causes X and Y to home, and Z to go to maximum after a print completes. That seems to have helped most of the time, though there are still times when it crashes, but at least this way if it crashes, the nozzle should miss my project.

I never got a good answer out of Snapmaker regarding the Z-axis droop, and one person there even suggested that this was “by design”, though that seems highly unlikely to me. Such behavior only causes problems, and has no virtue associated with it whatsoever. I took that to mean “it is an oversight in the design that we do not want to take responsibility for.” Ironically, about a year and a half later, I saw it listed as one of the fixes in a firmware update, though it didn’t help me much.

I’d say after a print, I had Z-Axis droop after about 20% of my prints. After my post-gcode changes, that dropped to about 10%, and of those 10%, I’ve suffered no damage to the printed part, because the nozzle was out of the way of the project when the Z-axis fell. The only time I had a nozzle crash into my project, after my changes, is when I had to abort a print before it was finished.

The funny thing about this scenario is how easily the Z-axis droops, yet how hard it is to lift it up. It seems to me the gearing is somehow backwards.

While I used to fume about this issue, it is now an irritation I’ve learned to work around. I still love my little snapmaker. It yields great prints. I’ve learned to accept its imperfections, consoling myself with the fact that it was essentially a “beta” product. I have higher expectations for version 2, where I hope they have learned from issues like this, and corrected for them. Perhaps one day, there will a be a solid, documented fix for this issue, but I’m not going to hold my breath on that.


#30

I’ve made a test: jogged Z all way up, marked the height and left it with the power on for the whole night. It was on the same height in the morning so looks like I’m lucky enough with this. Funny, this time it didn’t slide down when I turned the power off. Maybe it falls only when the assembly is still warm after moving. It continues sliding down if I switch the power off shortly after any Z movements.

@moonglum,
By the way, have you tried swapping X or Y linear modules with the Z one? Since not everybody experiencing this problem, two other modules can be free of it.


#31

@rochinaa
I’m glad you found a livable work-around.

X and y are only 125mm. Z is 221mm. That really isn’t an option anymore… but I have swapped Z, by virtue of performing this upgrade. It droops on the 125mm Z and it still droops on the 221 Z. So, I still think this is a problem with the design.


#32

@moonglum,
So both of your Z-modules from different (obviously) production batches slide down even when the power is on? Can it be some controller issue then? Maybe the controller cuts off the step engines after printing instead of holding them?

I believe you’ve already tried connecting Z-module to the other Z port or replacing the cable. There’s no spare controller in the kit to try the replacement, unfortunately…


#33

@moonglum firmware 2.9 locks the z axis when power is on, but not prevent it sliding down when power is off. The essential problem is still mechanical, that the resistance of the screw shaft is not big enough to lock x axis and the head.


#34

Yes, that sounds right. Let’s hope that this is no longer an issue in v2.


#35

Odd, My machine remains weeks on end without power, and the Z axis doesn’t shift a bit regardless of where the head is. (…now let me find some wood to touch…).


#36

Ditto, My SM1 is now 20months old and works like a dream, my X-Axis has not dropped. Maybe those with the problem need to speak to their Snapmaker and tell it to get its act together or @Rainie will turn it into door handles.

Doug


#37

Well, my original short Z-axis doesn’t slide (and never did). Only the long one slides. It’s not a problem actually since it stays still when the power is on, and I always remove the print before switching the machine off.

BTW I think (but I’m not sure) that now the distance it slides is a little less than before. Maybe the grease became more dense or the friction became a bit stronger. So there’s a possibility that it will stop sliding someday.


#38

The original firmware I used 2.4, has the problem, this even happens once I wanted to level the bed, when it go from the original point to point 1, the z axis falls…this leaves a beautiful scratch on my heating bed…


#39

Both of mine crash upon print completion. Long Z, and original Z. Nothing helps yet. I just put gcode in after the print to try to get the head out of the way so it doesn’t hit the part.


#40

Hi, I had the same problem with the z axis extension dropping. I’m still having a problem with the printer crashing stating “thermal runaway” which I am trying to now sort out.
As for the z axis dropping I have fixed the problem. I replaced the servo with the servo from the original snapmaker z axis, the z axis extension now works perfectly and doesn’t drop even after turning off.