Z-Axis falling down?


#1

Is it normal for the Z-axis to “fall” after a print or when I turn my Snapmaker off? If I jog the Z-axis up, after a while it will settle back down to 0 on its own.

I don’t think this has affected printing yet, but I’m afraid it might and I’m almost certain it would affect CNC and laser engraving, so I haven’t tried either of those yet.

If this is normal, I’ll leave it as-is; if it’s not, I can swap the Z-axis actuator with another axis (probably Y) as it appears to function just fine aside from getting pulled down by gravity when sitting idle.

I would think this was an automatic function of the Snapmaker, except that it happens when the unit is off and unplugged, as well.


#2

I don’t know about normal… but I can say that mine is not falling down… but, it is really easy to push it down. I notice this mostly when loading filament. I notice that the opposite is not true. When I try to move the X arm back up the Z axis, it will not let me (but the slightest downard pressure, and it falls down without much resistance at all). That didn’t seem normal to me… your problem seems more extreme though.

I’d be curious to see what others say…


#3

Well, they demo the dang thing with 2 spare linear modules sitting atop the X-axis so you’d expect it’d be able to hold that weight in actual use.

I do have a camera mounted to the X-axis arm which is adding some weight (less than 3oz in total, including the printed bracket). Camera + 3d head combined weighs less than the CNC head, so if that’s too much weight for the Z-axis linear module to support, I;'ll never be able to do CNC with it., period.

@Rainie what’s your take on this?


#4

Having the same issue on my end but with some other abnormal behavior. On occasion, the Z-Axis quietly falls down until making contact with the base plate… creepy enough. However, there are times while jogging that the Z-axis will not not go up/down. It will go so far and then stop and continue no further. Some times it is in the up direction, sometimes in the down direction. Actually caught a video of it not working properly.

Worth noting, I think it might be impacting my prints. I have tried to print the benchy model a few times. I thought it was failing due to adhesion issues but tonight, I heard a “rip” as the extruder impacted the model and tore it from the bed. Screen shots highlight where the extruder impacted the print.

@Rainie , you were amazingly helpful with my laser module, would love to hear your thoughts on this one.

Video / Image Files (zip file via Dropbox)


#5

I’m a little disappointed in the lack of response on this, especially given how short the warranty is. @Rainie, can we get you to weigh in on this?


#6

Hi @ogundy @bCreative,

Thank you for your feedback.
If the axis drops when it’s not printing and when you press it down, it’s normal.
If it drops when it’s printing, that is not normal. There may be 2 reasons for this issue:

  1. the printing speed is too high. Make sure the travel speed is lower than 70 mm/s.
  2. Some of the screws to immobolize the linear guide is loosened. Please follow these steps to troubleshoot:
    1. Power off the printer and detach the linear module that leads to this problem from the printer. Detach the 3D Printing Module or the heated bed on the module.
    2. Move the slider up and down. If you can feel the slider is not firm enough, in the up and down direction, use the provided screwdriver and tighter the following 2 screws. Please hold the slider according to the following picture when you tighter the screws.

Try to print again after the above steps. Will it drop again?

Look forward to your reply. Thank you!

Best regards,
Rainie


#7

Thanks for the response. Also… YIKES! That is really not ideal at all! I’ve had the head fall onto the edge of a freshly completed print and leave a mark!

I’ll try tightening those screws to see if it helps, but I’m sure I don’t want them too tight, lest the slider not be able to move at all.


Troubleshooting
#8

Thank you @Rainie fir the response. I will give it a look when I get home. As a followup question, any ideas on the inability to jog the axis from the video linked in my comment (link below)? That one has be strongly concerned.

Video / Image File


#9

Hi @ogundy,

The module cannot go down and left, the heated bed cannot go back at some point because we added software limit switches in these directions. To allow the module to jog the full work area, it needs to know where the starting point is. That’s why there is a feature called Home Axes in the Controls menu. After you tap Home Axes, the module will go back to the correct starting point and it should be able to jog the full work area after that.

The problem you showed us in the video occurs because the module didn’t go back to the correct starting point. The printer took the position where the module was when the printer was turned on as the starting point. It will not go left, down or back further than where the starting point is.

Therefore, please tap Home Axes before you use Jog Mode. The problem should be solved. If the problem persists, please share a video with us and we will look into it.

Thank you for your feedback.

Best regards,
Rainie


#10

Hi @Rainie ,

Thanks for the explanation. The Home Axes and Jogging isn’t really clearly defined in the manual (that I can find). As someone new to 3d printers and the processes involved, can you help me understand when and why I should use the jogging features? Is there something in the manual that I missed or a forum post about it that I am not aware of?

Thanks again!
Oz


#11

Hi @Rainie ,

I took to tightening the screws but they are quite literally as tight as they can go. If the head drifting is when the printer is not in use is normal, then I guess I am ok, though I do share @bCreative 's concern about drifting down into a completed print.

Thanks
Oz


#12

Hi @Rainie ,

Just wanted to let you know that, after using the Home Axes option you described, I have not had this issue. Thank you for the info!

Oz


#13

The z-axis had fallen down. I pressed Home-axis at the touch panel. The nozzle got stuck/trapped at the corner of the heated bed and the head didn’t go up, the head moved left and right, the bed tried to move backward: terrible noise! The nozzle left two marks at the edge of the heated bed. See photo.
snapmaker%20homing%20mark
I pulled the head upward manually. After homing again everything worked fine.


#14

I’m having the same issue. I can home, jog the Z-axis to the top, and then I can watch it start sinking. Every now and then, it’ll drop a little bit, and I’m no longer able to jog Z+…snapmaker thinks the axis is already at the top.

Those little screws are as tight as they can be, but I don’t think that’s the problem. It’s not slipping, but rather the whole linear actuator rod is turning as well. Does anyone have any suggestions? My snapmaker has destroyed the last 3 prints I’ve tried, when the Z-axis sinks down and wrecks it. :frowning:

Edit:
Here’s a video of the Z-Axis dropping after I jog it to the top.
https://photos.app.goo.gl/ATWVXxuk6G5Tuuud7


#15

The Z-axis is underpowered AND the lead screw is efficient enough that it can be back driven. You shouldn’t add any weight to the X-axis. Some people have swapped one of their other drives and solved their Z-dropping problem. This has been a problem for a number of people.

Proposed SOLUTION: Add a planetary gear reduction between the stepper motor and the lead screw. I think one would fit. It would take the place of the flexible connector and serve that function as well. The extra reduction should also add enough friction to the drive so it couldn’t be back driven.

Alternate solution: Add a back lock so it couldn’t be driven down. We use two different back locks in our prosthetic devices. They tend to be a little finicky. Ours prevent back driving in both directions while this application only needs it only in one direction.


#16

The Z axis isn’t underpowered. The axis only falls when the motors are turned off. M84 command turns the motors off after a print then it falls. The jog mode must only give a command to move the motor and then turn it off again because I’ve had it fall during then too.


#17

The back lock would have to be activated only when motor power is off. When motor power is on, you want two-way movement.

The gears are churning in my brain as to how dual bearing setup would work to replace the plastic end piece on the lead screw: one radial bearing and one one-way bearing. The radial bearing would need to be able to turn freely when motor power is on and prevented from turning when motor power was off.

Or, it could be as simple as a solenoid engaging a brake.


#18

Our back lock is a passive device. It allows the input (motor side) to drive in either direction. It doesn’t allow the output to be back driven in either direction. It is a little hard to visualize without an animated graphic. It uses a spring clutch that in the back driven direction wraps around a grounded cylinder and prevents movement. In the driven direction it is pushing on the spring end to unwrap the spring from the cylinder which allows movement. The mechanism from the input side pushes on one end of the spring for one direction and then pushes on the opposite end of the spring for the other direction. The output side does the same thing only it pushes on the spring clutch to cause it to lock up. It’s a clever little devise.


#19

There have been reports of the Z-axis falling under normal operation. The firmware limit on Z speed is 25mm/s which is due to it being under way more load than the other two axes. Most people don’t have any problems, many do, therefore my assessment that it is under powered. It’s marginal and needs to be beefed up so nobody has problems.

The Z-axis doesn’t need to be fast for 3D printing or laser etching. It should be as fast as X and Y for true NC milling (which it isn’t). Gearing down the Z-drive would be a good solution. It would solve both the backdriving and the weak Z problems. A bi-directional back lock would only address the falling problem.


#20

@Rainie, @whimsycwd,
An alternate solution to this problem is to use a different lead screw for the Z If I’m seeing this screw right it’s a 4 entry liead screw (meaning that there are four separate threads vs a single one) you could switch to a single entry thread which would effectively make the Z axis 4 times stronger and 4 times slower. Although because this is being speed limited by the firmware it could be made to move just as fast because it now has a better lift ratio. Maybe it could even move faster in practice with the improved ratio. You should seriously consider this change.