I'm running into problems where my Z isn't going down

When I tell my Z to go down, it won’t. When doing it through my computer it puts off the following error.

echo:endstops hit: Z:-0.00

Does anyone have any idea what to do? I’m contacting support about this also btw.

Maybe your endstop is stuck at the on position. Try turning it off and pushing it down until you hear a click. If there is none you need to check the endstop.

1 Like

My problem was similar. My Z axis was stuck at -0,00 (but high up in the z axis), and would only go up, it still had some space to go up from the 0,00 it showed and it does move up but NOT down!
I had this problem with the X axis as well.

I solved it by disconnecting all the wires both from the print bed, touchscreen, the 3d printing module, and the controller, dismounting the z axis and checking the end stop. The end stop was fine.
After putting everything back together, following again the instruction sheet, the computer and the touch screen of the printer resumed working!
I tried a print of a very small part (14.3x6.0x4.0mm), it printed great using a snapmaker filament.
Hope this help if you still have this issue.