X axis grinding noise SM

I have just reported this to support but am really frustrated! This is what I have sent to support in two emails. I really need to get this fixed in the hope someone here might have an idea. (also posted to facebook). It’s suggested I test the limit switch although the M119 test seems that the X axis is ok.

I previously (in February) reported an issue on my (new in December) Snapmaker 2.0. The X axis was making a grinding noise. At that time i took the X axis apart, couldn’t find anything wrong, but decided to order a new one which I installed the first week of March. I have used it without issue and actually not done a lot. Several 3d print jobs and a few days ago did my first CNC project. No problems until today when the new X axis is exhibiting the same behaviour. See video at this dropbox link.

I have several orders I need to fulfill asap and now am stuck. I need help as quickly as possible please.

and then followed up with this email.

For what it’s worth I did the M119 test. Results in image. Although it shows Y axis as “triggered” the Y axis when it homes is quiet as can be while the X axis is shaking while grinding.


Is it moving free if you push by hand?

Yes although there are a couple of “rough” spots but not bad - just not as smooth as the y or z axis. I was hoping I could just move it back and continue working but it won’t actually finish the home process while it’s grinding. I can’t believe this is happening twice in a row :(.

Have you tried "homing it by hand? Turn the machine off, push each axis all the way to its physical limit on the side opposite its cables/wires, then turn the machine back on and have it auto-home.

Anyway it’s a case for support…

You could try to remap the port to another, but I have never tried if this function works:

This would let you verify that the linear module or controller is defective.

1 Like

thanks for the suggestion. That is an interesting idea. I’ll research it more. Obviously I would want to make sure i can map back.


Yes - i have tried this. Support suspects the limit switch. That wasn’t an issue on the last one - never did find the issue and i just bought a new module. I would prefer not to have to do that every month of course ! Thanks for the suggestion

Just as a followup the limit switch is toast. I opened it up and the switch fell apart. This is my second module in two months that has had a limit switch problem. Shouldn’t these be replaced under warranty - I can’t keep shelling out of pocket every month to replace them. I was able to remove the switch assembly and I see it plugs in so I guess it’s replaceable but dealing with those little nuts must take a special tool.

Great you have found your issue.
The screws of the limit switch should be allen screws.
I use the 2.0 since early Kickstarter and never had issues with the endstops, so hopefully you have more luck with your replacement.

You bought the machine new in December and you have already purchased a replacement linear module? You shouldn’t have to buy any replacement parts for such new machine. Why did you do that?

Good to hear :).

I have found support is very responsive but we were messing around trying to figure out the cause (I had the same grinding issue in January). I had stuff I needed to get done and after being down (also Chinese new year) for about 4 weeks I just bought a new module. Now of course the same problem with the new module. sounds like support will send me a new switch.

Exactly right. I always keep spares on hand regardless of warranty or not. Time is money.

Agree - I’m going to make sure I have extra switches on hand - user on facebook gave me a link to third party switches so I’m checking that out.