Using Artisan with LightBurn

Dear makers,

Good day to all. :smile: We’ve recently updated the Wiki on Using Artisan with LightBurn. You can check out the instructions below. Hope they are helpful to you! And don’t forget to comment below if you have any feedback or suggestion :hugs: !

1 Like

Hi Snapmaker,

Does anybody tested this with Artisan/40W Module? It looks like this Configuration makes LightBurn generate GRBL GCode, but afaik Luban generates Marlin Code.
So my test was not successful and the Problem with relative Coords as mentioned in 40W laser running out of boundary (lightburn) - #22 by mchytracek is not solved by this solution because Lightburn always generates G91 command for fill and offset fill Mode layers.

Regards Michael

Reading the lines of the settings, they’re all setup as GRBL machines. The 2.0 and Artisan run on Marlin, the Ray is GRBL. I’m going by the 40W on all three for the analysis.

"StartGCode": ";header_type: laser\n;machine: sm2\n;gcode_flavor: grbl\n;renderMethod: line\n;max_power: 255",
"StartGCode": ";header_type: laser\n;machine: artisan\n;gcode_flavor: grbl\n;renderMethod: line\n;max_power: 255",
"StartGCode": ";header_type: laser\n;machine: Ray\n;gcode_flavor: grbl\n;renderMethod: line\n;max_power: 1000\nM2000 W1 P255\nM2000 W2 P255\nM2000 L13 P0",

Few interesting control codes included on the ray, three different M2000 commands, W1 P255, W2 P255, and L13 P0

The first two, I’m not sure of, likely some kind of fan or light control for the enclosure, the third one is an interesting addition as L13 is the crosshair control, P0 turns it off, yet there’s no line turning it back on in the end gcode.

We DO get some macros with each, however! Notably the parameter changes between machines for controlling the same thing, particularly the crosshairs, note the start gcode on the ray L13 P0 matches the Artisan, but not the 2.0. Bonus points for half dodei mode :upside_down_face:. We also get a few extras on the ray which are GRBL specific since it runs GRBL, along with some enclosure commands. Oddly, no crosshair macros.


"Macro0_Content": "M2002 T3 P1\n",
"Macro0_Label": "Crosshair On",
"Macro1_Content": "M2002 T3 P0\n",
"Macro1_Label": "Crosshair Off",
"Macro3_Content": "M2000 L23P0\n",
"Macro3_Label": "Half Dodei Mode On",
"Macro4_Content": "M2000 L23P1\n",
"Macro4_Label": "Half Dodei Mode Off",


"Macro0_Content": "M2000 L13 P1\n",
"Macro0_Label": "Crosshair On",
"Macro1_Content": "M2000 L13 P0\n",
"Macro1_Label": "Crosshair Off",
"Macro2_Content": "\n",
"Macro2_Label": "-",
"Macro3_Content": "M2000 L23P0\n",
"Macro3_Label": "Half Dodei Mode On",
"Macro4_Content": "M2000 L23P1\n",
"Macro4_Label": "Half Dodei Mode Off",


"Macro0_Content": "$X\n",
"Macro0_Label": "Unlock Machine($X)",
"Macro1_Content": "M2000 L23 P0\n",
"Macro1_Label": "Half Power(40W)", (Aha! They abandoned the half-diode name)
"Macro2_Content": "M2000 L23 P1\n",
"Macro2_Label": "Full Power(40W)",
"Macro3_Content": "$S\n$I\n",
"Macro3_Label": "Machine Info",
"Macro4_Content": "M2000 W5 P0 Q0\n",
"Macro4_Label": "Enable Enclosure",
"Macro5_Content": "M2000 W5 P1 Q0\n",
"Macro5_Label": "Disable Enclosure",

A few oddities and noteworthy things I found;

"UserOriginX": 0,
It’s 0 on the 2.0, but on the Artisan and Ray it’s set at 31. :thinking:
"BaudRate": 460800,
The Ray uses a weirdly high bitrate.
"ProcessOffsetX": -21.600000381469727,
This is set on all three, should be the laser crosshair offset.
"Info": "",
We got an internal IP. :slight_smile:
"LastMachineFilePath": "C:/Users/BC/Downloads",
And a user path!

Thank you for reading today’s episode of over-analyzing mundane things with Skreelink. :upside_down_face:


I can get the Artisan and 40w laser to run on grbl not snapmaker (Marlin) but they keep saying it needs to be running under marlin to use the rotary module for the lightburn software. Did you get yours to run under Snapmaker (Marlin)

The 40W Laser Module runs on Artisan with the Snapmaker(Marlin) Device profile. Cutting works, but engraving (Mode fill and offset fill) does not. See this thread:
Meanwhile Snapmaker said that the issue has been found and is fixed in the next firmware release (which has been released today).
So i have not tried out the new firmware with the 40W Laser because of doing some 3D printing right now.

1 Like

How do you connect to Snapmaker (Marlin) mine won’t do anything under laser is says ready in the console it says waiting for connection and under that it keeps saying G0

I have the new firmware update and lightburn 1.5

The workflow is described in the linked forum posting

i have the same problem. i followed the steps from the tutorial, but i still can’t connect…

Can’t find anyone to help or who’s knows about this does grbl work for you?

I can run lightburn fine on grbl I want run the rotary module and it says I need Snapmaker (marlin)

When I click show all it says G0

I can run lightburn fine on grbl I want run the rotary module and it says I need Snapmaker (marlin)

Yesterday, I couldn’t get it to work at all. Not even through Grbl. Today, I don’t have the nerves to test it again.

Wonder why some people can get it to work on Snapmaker Marlin and some can’t

Bumping this thread because I’m running into the same problem. Followed all the instructions but despite the ready connection, the console says waiting for connection and just spams G0.