USB Port not working now

I have submitted an email to support@snapmaker but I figured I’d post here as well.

I need to read some files from the USB drive and when I plugged them into the snapmaker, it registers that the usb drive is plugged in, but not recognized.

I reformatted three thumb drives as FAT32 and tried again, just to be sure. It won’t read any of the drives, even my brand new seagate portable. I get the error that the drive is not recognized. The drives are recognized just fine by my computer and Xbox One.

Processor Intel(R) Core™ i7-6600U CPU @ 2.60GHz 2.81 GHz
Installed RAM 16.0 GB
Device ID 3F0E4050-CBC3-44C0-ACFC-7930DBA110D4
Product ID 00330-62831-47465-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch Pen and touch support with 10 touch points
Windows 10 OS

Snapmaker 2 A350
Firmware 1.14.1
Luban 4.1.1

Could there be something wrong with the port on my machine?
…if so, what do I do?

Is the USB port over 8 or 16GB? I don’t remember what the limit is but many people have had to use smaller thumb drives.

Do you still have the one that came with the machine? If that’s the one you’re using and it’s suddenly stopped working then that would be a concern.

I tried a 2GB drive, a 512MB drive, and another 2GB drive. The Seagate is a big 1TB drive.

I dug up the little silver one that came with the snapmaker and it DOES get read… but when I plug it into my PC it says it needs repaired (I did not do so). I wonder why it won’t read the other ones though? It did previously read a different drive. hmm…

1 Like

It always says it needs repair but it’s never been a problem that I’ve heard of. I also never repair. There’s probably a metaphor in here.

The machine is definitely finicky with drives, I can’t say I understand it.

1 Like