USB, Firmware, general failures

We have an A250 that I’m attempting to use, but the usb port doesn’t seem to recognize anything. I’m formatted, tested multiple drives, restarted with/without the drive being inserted, nothing.

I then tried to update the firmware in hopes that this would fix the issue, but I can’t seem to push firmware without USB!

Using Luban to push to local files won’t work for .bin files, and attempts to use the “firmware tool” within Luban does nothing.

Instructions say to navigate to settings > Firmware or Update when connected to Wifi, but this setting doesn’t exist.

Currently running:

Snapmaker 2.0 A250
Touchscreen version: V1.8.0.0
Controller version: v1.8.0.1_20200603

Have you tried with the drive the machine comes with? It’s extremely picky on what USB drives it will accept.

I’m not sure we still have that drive! I’ll dig around and see. Do you know what size it is? I wonder if its not reading larger drives possibly?

Fat32, 8k cluster, I think someone said it worked with a 64GB drive. I think the original is 16? Maybe you can search the forum better than I can, that’s all I could find.

My original came with a Kingston DTSE9 16GB. Looks like this one is USB 2.0, not 3.0.

I know there is a transition at 32GB (scroll to the bottom for the exFAT filesystem info). It was a common problem with old Android devices and larger SD cards.