Updated linear rail issues

Hi all. I bought a set of new upgraded rails for my A250 from an individual. I hooked them up and turned on the machine. The machine recognized the new modules, downloaded 2 updates and installed them automatically. The rails don’t move. They lock into place when the machine is turned on but won’t jog or move at all when commanded. I then tried to reinstall the firmware via the USB port but the flash drive is not being recognized/seen but the machine. it’s the same drive I’ve been using for a couple of years and it works in my A350 so I know the drive is OK. I hooked up to the machine via Luban. It’s reading the machine’s setting when I input M503 but the rail location and head information that is supposed to be displayed in the lower left panel is only reading “detecting”.
I also tried hooking up 1 of the old rails all by itself to see if it would move when commanded. It did not. I then hooked the same old rail to my A350 (by itself) and it does move when commanded.
I hooked 1 of the new rails to the A350. it would go home but would not move when commanded.
Considering all this I believe that the update got borked somehow.
Any suggestions?

Are you sure you do not mixed old and new modules and used the 20mm and 8mm on the correct place?
I think they added some Logic and consistency checks later on that only correct and defined configurations work.

With and old firmware I was able to use a a350 Module in my a150 for z. With newer firmware this stopped working.

Not mixing modules. I disconnected the new modules prior to hooking up the old one. I don’t understand the 8 and 20 reference. why is the USB port not working? Is there a way to reinstall/downgrade the firmware via Luban? Is there a special firmware I was supposed to install for the upgraded rails?

I just found what you meant about the 8 and 20. Fixing that now. Will let you know how it goes.

Everything is working except the USB port. Still looking for the answer regarding firmware changes being made through Luban. Anyone?

You can Open workspace in luban and send the Update file Like gcode.
Just Change the filetype filter to all Files and you are able to send .bin Files to snapmaker and install it from Touchscreen after.

I remember a other thread where the storage was full, this causes a not complete update and weird issues.
Is there enough space on the touchscreen?

Thanks. I’ll give that a try.
Storage is completely empty.

I reinstalled the firmware via my laptop. USB is still non functional. Is it possible to swap out the controllers between the A250 and A350? I can get along without the USB and I don’t want to sell the A250 with a bad USB port.

Yeah, there is no difference between the a250/a250t/a350/a350t controller

I took apart the controller and found 1 of the USB contacts and the connector were malformed. I was able to straighten both out and all is working again.
I’m going to put it on Craigslist for a week or two and then on eBay if it doesn’t sell on Craigslist. Wish me luck.