Unusual behavoir of 3D printing module while homing

Hello everyone

For a while I have observed that my 3D printing module is making strange noises. I don’t know if there is a problem with the module itself or if there is a firmware error.

I have made a little movie of the situation. Unfortunately the sounds aren’t perfectly perserved in the movie.

  • second 7-12 you will find “winding” kind of noise. As if there was a wheel (the filament transport wheel) or a fan spinning.
  • At second 24 a “rattling” noise is repeated several times as if the module wanted to advance but couldn’t go any further.

Has anyone an idea what could cause these noises and how to fix it?

Thank you!



Does it do this with any other module? The sound at 24 seconds sounds like skipped steps, maybe the limit switch is broken or shifted. I don’t think it’s really with the 3dp module itself, as it literally just consists of 2 fans, thermistor, heat block, heatsink, and a drive gear/motor. Since this is obviously in a homing sequence, I’m leaning moreso the linear modules being the cause.

Try jogging all axes to their center position and get a video of the entire unit to pinpoint when and where it happens.

Thank you Skreelink

I tried the CNC module.

As you say: The same behavoir.

Seems to be the linear module. It only happens in the end position (up, left if I look from the working plattform). Is this enough information for the positioning? Do you need the pinpoint part that you mentionned in your post? What do you mean by jogging all axe to their center positions?

How to fix it?

Thank you.



In the control screen, move the axes to their central positions. Center the head left/right, up/down, and the bed back/forward. Or you can turn the machine off and move them manually. Then start up the machine, go to the control screen, and record the entire homing sequence. The limit switch is built into the linear rails and sets the home position, it’s fairly important. Also, what specific machine do you have?

Hope this helps…

The maschine is a A350.

X axis linear rod limit switch has moved or broken. Contact snapmaker support for disassembly instructions and getting a new limit switch.


Thank you Skreelink. I will reach out to snapmaker support.

After I attached the CNC modul I wanted to recalibrate the 3D modul, which resulted in an error message. I have the impression the sensor which is responsible for sensing the building plate didn’t stopp the downward movement of the Z axis even though the light of the sensor lit up. As a consequence the building plate was pressed down a bit untill the modul moved upwards again to a resting position at which the error message was displayed.

To my understanding this shouldn’t be linked to the problem with the X axis, is it? What could be going wrong and how to fix it? This has never happened before.

Thank you!


So as “Skreelink” already writes the limit switch of the X-axis will be displaced or defective.

Your machine is an A350T or the my knowledge but I can also be wrong there is no A350 machine!?

But your Z-axes don’t sound very healthy either, have you loosened the X-axis screws where they are attached to the Z-axes and moved the Z-axes via the software to the end position above and then tightened the screws of the X-axis again.
This leads in many cases to a quieter movement of the Y-axis, because it sounds very much like braced axis.

The A350 was an original 2.0 model, the rails were not silent and were infact very noisy. The A350T is the new one with the quiet PSU, trinamic drivers, amd new 20mm leads on X and Y.


Ah ok, I did not know that, although I already had the suspicion because of the noise sounded like the old rails !!!
Thanks for the tip tip @Skreelink!


What do you think of my Z axis situation? Is it possible the distance sensor of the print modul is broken even if the light turns on? It hasn’t been very long since I last calibrated and at that time everything run smoothly. In fact I just printed something 2 days ago without a problem. Only since I changed to the CNC and back, there is a problem calibrating, that the modul descends to far and pushes down the building plate.

Thank you.


Are you sure that you have the module mounted in the correct holes? The sensor should still stop it, but just checking.


Thank you sdj544 I already had double checked. the module is mounted as it should be.

I ran a little test today. I lowered the Z axis while holding the spatula underneath. The light of the sensor lit up but the Z axis lowered even if it touched the spatula.

How did you lower it. Outside of a G30 or G38.x probe command the probe is ignored and will not block movement. Easiest check would be to start at a high Z and issue G30 from the USB terminal and then try the spatula. If it fails to stop immediately kill power.

Ok. No I just lowered it on the touch screen with the arrow buttons. But how to use G30? Thank you.

Requires using the terminal in Luban, either over wifi or USB. You could also just run a calibration from the touchscreen. If that picks up the spatula successfully then the probe is working. You’ll have to kill power and then successfully complete a calibration before printing again.

If the light turns on as you say it does, and it still pushes into the plate, then the most common cause is the sensor height is too high and it doesn’t pick up the bed soon enough. With the nozzle touching the bed there should a credit card thickness gap.:

Thank you brent113

Before I asked about the sensor the modul hit my building plate twice. Now I checked with the spatula while attempting to calibrate and the Z axis stopped. Now I launched a new calibration and it is working just fine… feeling irritated

1 Like

I’d wager the probe is just borderline too high and is inconsistent. Try lowering it.

Ok. Thank you! I will try that…