Unable to disable multipass in Luban 3.13.1 (MacOS)

I can’t seem to enable a single pass laser cut in Luban 3.13.1. The instructions here don’t work.

The “checkbox” for laser multipass is ALWAYS checked on the Mac. It seems to toggle between BLUE (On/checked) and GRAY (which I would hope is OFF, but it doesn’t seem to work). If I do select it, the # of passes is checked only takes entries of 2 or greater.

I have confirmed that both settings (BLUE and GREY) produce gcode with two passes.

My workaround has been to export and edit the gcode manually, but I shouldn’t have to do that.

Can anyone help me out by telling me what I am doing wrong, or confirming the bug (and hopefully identifying when it will be fixed)?

Many thanks!

It will always show the check mark (that’s the bug)
If it’s gray and isn’t showing options for number of passes then it should be off.
At least it’s worked that way for me.


Hmmm, not working for me. GREY is still producing gcode for multiple passes.
Have you tried on 3.13.1?

Yes. 3_13_1 on mac.
Are you sure you’re selecting the object you want to turn it off for?
Tried quitting Luban and restarting? Deleting and reimporting?

It’s not doing that thing that sometimes happens with a piece of artwork where it’s doing the inside and outside of a line and it seems like it’s doing a multiple pass?

Share your artwork.


That is a very probable cause. Here is the artwork. Admittedly, while I want it to behave like vector art, it is a PNG, and as a rastered image, Luban might be creating inside and outline outlines for the image.

I will find a Mac to reproduce this issue at our end.

NC file attached
single-pass.nc (75.5 KB)

Hi Edwin:

Thanks for doing the experiment on your side. If you actually open the gcode file (which I did in emacs), you will see that the single-pass.nc file actually has TWO passes in it.

I think that @sdj544 's hypothesis may be correct, because the gcode at the beginning of the “second pass” is as follows:

G1 X-2.94 Y138.33
G1 X-4.48 Y138.26
G0 X-5.64 Y137.88
G1 X-6.14 Y137.84
G1 X-7.12 Y137.73

After the Laser is turned off (M5), the laser is moved to a new XY position and then turned back on (M3). What is notable is that the Z position is not changed.

So technically, it’s not a second pass. It looks like Luban generated outside and inside edges to the curve.


Because you import the .jpeg file in Snapmaker Luban instead of a .svg file. When you select ‘vector’ mode, the software will simulate the path.

You can covert .jpeg to .svg and then have another try.