"Snapmaker" splash a few minutes after starting a print

Just today, my printer seems to fail after heating the bed, and 75% or so to heating the nozzle. The “Snapmaker” boot screen with 3 animated dots shows and never goes away… I was trying to print something that had previously worked before. I was just printing another. after an hour or so, the splash screen was still there and had not recovered… so i switched it off and on… same thing… tried another file… same thing…

Any thoughts?


This sounds like the problem I experienced. Have a read through this thread: About the Reboot Screen (White Screen)


ah… i went in that side panel… reluctantly because of all the “do not touch” wording on the warranty page. for a product made for makers, fixers, and doers… the warranty represents a serious misunderstanding of the target demographic.

I was able to something-something the cables and it seems to work now.

I am so thankful the web devs for snapmaker.com left out a store to buy spare parts, a “how to fix” section similar to what i would find at ifixit.com, and a troubleshooting section as a main category. :unamused:

i have lots of bed adhesion issues, issues where it seems like the extruder may be slipping on the filament. Overall, my Anet A8 has been a far superior printer in almost every way but looks…


And it doesn’t etch and carve.

yeah. you are right. but could probably mod it to do Pens, Markers, Carving, and etching…