Snapmaker Ray 40W work origin problem

I just received my Ray 40W machine. I managed to put it together and install it, I already have a Snapmaker Origin machine with a 1600mW laser, so I’m not a complete beginner and I also know Luban. But now I came across such a novel thing that you have to set the origin point manually.

The setting is: workpiece size 600x400. Work origin: Workpiece, position center, crosshair. I manually set the origin point on the workpiece (3cm circle), click Run Boundary, it shows the outline perfectly. I start the burning, the laser unit comes fully forward and collides with the end of the Y axis and starts burning there.

I changed the Work Origin setting to: object and now the run Boundary is perfect again and the laser burns where it should. I did this job with several different shapes and it was good.

But the error came again, I didn’t set anything in the settings, the problem now is that the run boundary runs perfectly. But when starting the burning, the laser goes out to the end of the Y axis and hits the end and starts burning there, not in the middle of the work. I tried restarting the machine, the computer, luban, no results. It doesn’t burn where the target cross is, but outside the boundary line. The machine has gone completely crazy, what should I do? Thanks.

I don’t understand this whole manual setting. If there is a work area (600x400), I place a workpiece in the middle of it, then it should start working there, right? If I can manually place the cross of the ladder anywhere, then what is the point of the coordinate, the work area? Are Y0 and X0 the home point, upper left corner? Or the center of the work table?

If you open a model in luban you are able to set your work origin by selecting a spot on your work piece or center and afterwards you should be able to move your model to a specific spot you like. This sets your work origin in your gcode.
After generating the gcode and loading to workspace you need to set the work origin in your machine by moving with the machine controls and setting the work origin before hitting start.

I don’t know what happens with your boundary issue, this is case for support…

Thanks for the help.

“I don’t know what happens with your boundary issue, this is case for support…”

This is what I don’t know either :slight_smile: because it used to work properly (so I did it right), now it doesn’t work, then either the machine or the luban is at fault. I contacted the manufacturer.

I have received the answer from the manufacturer, I will share it in case it can be useful to others.

"Thanks for reaching out to Snapmaker. I am sorry that you encountered such a problem.

Our product team has reviewed them and identified a firmware issue that might be contributing to the problem, specifically the abnormal triggering of the ‘Go home’ button in Luban.

This issue will be addressed in the next firmware version. For now, please turn off the machine and then turn it on again to resolve the problem.

I apologize for any inconvenience caused.

Currently, the issue with ‘Go Home’ is that, upon pressing it, the machine’s coordinates become confused. Restarting the machine aims to reset the coordinates to 0,0, ensuring proper functionality.

Please note that after restarting the machine, do not click ‘Go Home’ on Luban; otherwise, the coordinates may still become disoriented.

Thank you for your patience and collaboration as we work together to find a solution."

I’ve had my Ray 40W for a few months and have not had any issues like this. Here’s what I’m doing in case it helps someone while the software bug is worked out. I normally create my designs in Inkscape and then import SVGs into Luban to set up the cuts/engraving settings and running the job.

In the “Job Setup” popup you can set the origin mode and origin location. I always use origin mode = object. For origin location, I will change that based on the material I’m cutting. So I’ll put the material in the machine and decide where I want the cut. If usually cut starting from the top left of my material, so I’ll set the origin location to be top left. Once the job is ready to run, I use the red crosshairs to align the laser head near the top left of the material, do a boundary check, and then do the cuts. Since I used origin location = top left, I know the laser will be cutting down and to the right. This has worked great and I’ve never had issues with the laser running into the end stops or anything.

I’m fairly new to laser cutting, but I imagine the use for origin mode = workpiece is if you have a jig setup so you can put your workpiece in the same place every time, and cut the same thing over and over. For me, nearly every job is different, and every workpiece is different since I’m often cutting multiple things out of the same workpiece over time. I try to use the material efficiently, so I’m trying to position the laser head to fill in any gaps between prior jobs and use up all the space which means I’m changing where the origin location is as needed and moving the laser head to where I want the cut to start from.

My only gripe is that the red crosshairs don’t line up with where the cut actually starts. The crosshairs seem to be about 1" off. It’s not a huge deal since I just compensate for it when setting up the job, but it makes it hard to use every last millimeter of material since I don’t know exactly where the cut will start. (I was actually hunting for suggestions on this when I saw this post.)