10W Laser confuses Work Z Origin, crashes into bed

I just upgraded to the 10W laser. I’m running current firmware and software. The install went easily, calibration was successful, and the first several projects I did using camera alignment went without a hitch. Then I tried to run a job using a regular work origin (no camera background). They system homed normally, then the laser proceeded to crash into the bed.

I eventually tracked this down to the machine origin, which if it goes to zero will absolutely crash the 10w laser into the bed. I manually reset the Work Origin to a new zero, but I don’t understand why the Z element of the Work origin isn’t limited/set based on the initial focus calibration.

I assume that bad number was still sitting in the machine from the previous 1.6w laser head? If the machine homes, and the machine knows how big the 10w laser is, and it has a proper focus calibration (i.e. it has been told where the bed is), why is it still able to crash into the bed? Anyhow, watch out.

3 Likes

In Luban is it set for the 10W laser?

Yes, it is set to the correct laser in Luban.

Good warning to new 10w users! Just got mine on friday. I used luban to send the file over wifi to touchscreen and then ran from there where it forces you to choose manual/auto and goes to the page where you check / set the work origin. So are you saying you used the touchscreen and went through start calibration and then started a job and chose manual after completing camera calibration? I first tried auto, it stopped about 10cm about the auto-focus height and offered Run boundary etc. It all worked fine, I then tried another auto and some manuals, the manual was more scary and I think it may have returned to the last work height (about +1cm from next object), but can’t remember clearly. Wish they had more thorough testing plans, it leaves a lot of room for bugs.

1 Like

was this ever resolved? I just switched to the 10w laser as well. It calibrated well, but I am trying to run my first project and ran into problems. Connected Lupin via Wifi and told the machine to go to work origin. It crashed into the corner of the bed. How do I correct this?

No, clearly not resolved. I find I have to regularly reset the work origin, and for reasons I don’t understand it will erase the work origin without warning and then crash into the bed all over again. This machine has the absolute worst software I’ve ever had the displeasure of working with. Every time I have to use this laser I’m guaranteed to waste an hour of my life dealing with some new and unexpected screwup. If it hadn’t cost so much money it would be in the garbage.

The work origin must be set every time you print, there is nothing to save. That is the definition of work origin, as work = print. If you are looking for some kind of batch system, with a fixed repeatable bed position, you can’t do that with Luban. You’ll need something like Lightburn for that, though I don’t remember if the TouchPad has support for this scenario.

Same thing just happened to mine on the first run. Designed a simple file in Luban, started the laser cut in luban, and the laser immediately buried itself into the laser bed. I’ve read the comments above, but am not clear on how to prevent this from happening. Can we please get a software update or something? I feel like the calibration process should prevent this from being a possibility. Like this is madness.

I found that creating the job in Luban (object import, job settings) and then starting the job using the touch pad (select job, auto-focus, set work origin) got the issues to stop. Hopefully they fix Luban at some point, but the touch pad method isn’t too bad.

first thing first, this is the exact issue facing too the questioner have defined, new laser module got crushed on the bed. I guess Snapmaker must aware users when they sending new buyers 10W laser with the issue they can encounter, so after installing and calibrating they must sure before running the test ruler laser test project, what necessary steps they should take or do to avoid crushing new brand 10W laser into the bed. I really disappoint from this way of selling things when we can make wonderful things out of it! isn’t it their slogan? ok well.
so I found is, when the tool head focus, camera calibration and thickness calibration is done from laser 10W module, at that time we must set that position as work origin in workspace . so when you say in workspace go to work origin it will come and set to that place and then we can manually figure it out not using Auto Thickness calculation instead from option set work origin when starting new job, where to again set the work origin or z offset from the material thickness which can stop this hitting to bed issue of 10W laser module, but its still tricker to adjust the laser dot or so. (complicated stuff)
Snapmaker kindly aware buyers over this issue so they won’t loss newly brought module like that and feel sick and sad! hope you understand!

Will be sharing video links of this issue and worked out method so far as described in the comment above. Thanks