Help with Origin Issue on New Ray

I have just finished setting up my Ray machine and was attempting a test cut. I position the crosshairs on the test material and created a small square to cut in Luban and when I run the boundary it runs correctly but when I actually start the job the toolhead immediately runs to the lower left of the machine and hits the stops. What am I missing. I did not see anything in the “documentation” or this forum, so I am unsure what setting I have wrong. The machine and luban have been updated to the latest versions.

I do wish the machine had an interface other than the single button. I missed the touchscreen that my Snapmaker 2.0 has for feedback.

I also don’t like the fact that I when I have to switch machines Luban has to complete restart the application. Oh well, I am sure that it will get better as the application is being updated.

Okay small update. I was able to get a test cut when I generated the gcode file with LightBurn. LightBurn is my preferred application anyway but I still want to know what is going on with the file generated in Luban. I suspect it is M2003 or M2004 which are Crosshair and move commands related to the crosshair. I haven’t tried turning that off or comparing the generated gcode sequences yet but that is on my list. Now to build the enclosure and get the air purifier hooked up. It is signifigangly more powerful than the 10watt that I have on my SnapMaker 2.0 system. For 3mm bassword it was 100mm/min @100% and with the 40watt it was 780mm/min @ 100% and so much cleaner with the air assist. Looking forward to getting it fully running and trying on thicker items and metal :wink: Will report any findings…

If you upload the gcode file generated in Luban I might be able to tell you. My guess is you manually move the head where it needs to go, but then Luban is generating a job in absolute coords and moving to the existing home.

You could try moving the head where it goes, then in Luban typing G92 X0 Y0 before trying to run the program. This will set the home location to the current location of the toolhead.


If I don’t use crosshair mode for the file, it works fine. So I am thinking there is something wrong with the M2003 or M2004 command that is only generated when crosshair mode is selected.

if (headType === 'laser' && jobOffsetMode === JobOffsetMode.Crosshair) {
        'M2003', // crosshair offset
        'M2004', // move

I am still looking into this some more but I can now generate files from Luban and Lightburn so I am closer.

1 Like

I had the same issue. The test drive was fine but when i pressed the button for more than 3 Seconds to start the job the toolhead crashes immediately in the stop position. The reason was the chosen origin point in the luban software. I dont know the exact dropdown menu but you have to chose “origin based on workpiece” and not “origin based on working area”. Maybe your issue has the same reason.
Your post is 12 days old but maybe its helpful for something else
Best regards

I’m new at the forum and just got my Ray today.
first try out was a dissaster, I even thougt my machine was faulty until I found this post.
I’m using luban, I have 2 snapmakers 2.0, one as a printer an another with the 10W Laser so I dont have lightburn yet.
Same problems here, boundry is ok, but when the job starts it just move to one corner (left front) and tilts there .
Changing “orgin based on workpiece” didn’t work for me.
After understanding it was a problem related to the poin of origin, I’ve tried using “center” wich is by far the less apealing to use but it works perfectly.
So from my point of view this is a software/slicer problem.
My luban is the latest (4.10.1) and the firmware on the ray is also the latest available.
Hope they fix it soon because I’m familiar with luban.
It’s also a pain in the a## to have to change the machine setting manually every time we connect to a difrent printer.

@detlefgrohs @Lukasrau @xally
Our product team has identified an issue that may be contributing to the problem, specifically the abnormal triggering of the ‘Go Home’ button in Luban.

Currently, the issue with ‘Go Home’ is that, upon pressing it, the machine’s coordinates become confused, resulting in the situation you are facing. To resolve this, please restart the machine and refrain from pressing the ‘Go Home’ button moving forward. Restarting the machine aims to reset the coordinates to 0,0, ensuring proper functionality.

This issue will be addressed in the next firmware version. I apologize for any inconvenience caused.

Please note that after restarting the machine, do not click ‘Go Home’ on Luban; otherwise, the coordinates may still become disoriented.

I updated the firmware, but when I tried running a boundary on the ruler sample, this time the toolhead went all the way to the right, bumping into the enclosure wall. I’ve had the thing for a month but still have not been able to use it.

Hi @KeithP

Sorry to hear that. I recommend reaching out to the support team by submitting a ticket; they’ll be able to assist you in resolving the issue.