Snapmaker Original Controller broken

Suddenly my Snapmaker (Original) stopped working.
When I turn Snapmaker on,
The following happens:
(1) Fan in the controller unit
(2) Fan in 3D printing head

Does NOT work:
(1) Touch pad is blank,
(2) USB cable from controller to computer does not get any response from the computer.
(Tried changing to different cable, no luck)

Usually the above is the case, now.

But once the following happened could not reproduce it yet.

After keeping Snapmaker on for some time,
suddenly the computer recognized the Snapmaker,
with the familiar “new device recognized” bell.

I fired up Snapmaker Luben and started printing.
The Touchpad also lighted up.

Snapmaker started making a loud rubbing noise, while moving the
print head and the hot bed.
After 3-4 seconds the sound went away.
The printing was incorrect, the print head was too high from the hot bed.

So I stopped the print from Luben and started calibrating using the Touchpad,
before I could touch the first point for calibration, the Trouchpad died, and
I heard a bell noise from the computer for the USB connection being dropped from the
Snapmaker controller.

Looks like a controller problem to me.
Any help Is appreciated.

I am out of warranty, I bought it on Jan 2019, and just started to use it now.
The controller costs $90 (from other stores NOT from snapmaker!!) .

Only used Snapmaker at most 15 to 20 hours.

Any help is a appreciated for debugging this.

Why the heck is there a sudden influx of people saying they have a rubbing sound on their original snapmaker? you are the third.

One person said earlier they disconnected their display and reconnected it earlier

You should write to to get their price, I guess it would be less than 90$.

If you connect to your pc now, do you get a connection or not?

That is the problem, the USB cable from the Snapmaker Controller does not get detected in my computer,
when the Snapmaker is turned on. Also the Touch display remains black, but the print head gets power.
Checked the power supply, around 24 volts.

I did not see the link to the Controller in Snapmaker store. If you find one please let me know
Thanks for your suggestion.

From what I’ve read on the forums, the only way to buy the controller or linear modules is by contacting support.

Thanks, I have sent a email to support.

Support asked me to look into the LED of the controller, which is located near the fan and send a video of the malfunction.
The LED was not glowing at all, I do not even remember seeing it, because it is at the back of the machine. Any way they are going to send me a new controller $89, and shipping $14, total $103.
I paid using paypal to a Chinese name, written in Chinese. image
I hope the hardware for the controller has changed, from what I had and the new one, which I am getting, otherwise this might again go bad. They did not explain to me what went bad, it is partially working.
If any one knows about the hardware version changes for the controller, please let me know.
Also If you have any idea, how to debug the controller hardware, please let me know.

Got the new controller last week.
Printed few parts, worked fine. The fan noise is low in this one.

1 Like