Snapmaker has the wrong positioning

Seems to think that the top of the linear module is 0 Z and the nozzle being at the very left is - 17x while the print bed being all the way forward it counts as 347, and then beeps when I try to lower it. So far my experience with this machine is less than bad and has just degraded to frustrated beyond belief that out of box it’s such a broke machine :sweat_smile:

I’ve double checked all the connections 4x and unplugged everything and replugged it back in 2x


***Edit
When hitting home button it actually does register Z as being in the 300’s for half a second before dropping it back down to 0

Hey @Mika, i am sorry to ask this.
Are you sure you have connected the Z Axis right?
The cables should run out at the bottom of the linear modules to the connector box and then to the controller Z-Axis port. The same should be at the y axis.

If you got cabled it right, please try to outcross the two connectors at the controller.-
BUT BE CAREFULLY WHEN HOMING, if you do this, you should have one hand at the powerplug/button/switch!

Someone knows where the HOME-Pos. of Snapmaker 2 is?

At Snapmaker 1 the home Position is:
X, Printhead all to the left
Y, Bed all to the back
Z, all down

EDIT: X:-4.50 Y:-5.50 Z:0.00 E:0.00 are the home pos. of snapmaker 1.

I hope this helps you a bit.
Greets Chris

10000000% sure it’s the right connections, as I’ve said I literally redid all the connections 3x and have rechecked them 5 times total. It’s definitely all hooked up right. Also the z does register in 300s when homing then after it finishes homing and setting itself to 335Z (which it reads on the touchscreen), the number jumps to 0 when homing completes. Not sure what outcrossing is but I’ll look it up and try it

it seems that the encoders are counting in the false direction, like the drives run in the false direction :thinking:

could you send commands with the terminal?
try to send the printer to the home position manually with the command G28
lets see if it drives all the way back after homing

Here’s a video of me homing after booting. I pushed the piece down to the bottom (while off) to show it does actually seem to know where it’s going. If you watch after it homes the first time, I press home again and it corrects itself to the proper z before reverting to 0

drive.google.com /file/d/1F_WKsPDZmbBMt8zAG5YEwjtY9fWwffUg/view?usp=drivesdk

I tried with the terminal in Luban and same thing, it goes to the top

Looks like it’s a firmware bug, email support responded with the following which worked:

1, Connect the machine with a computer via the provided USB cable, and then open the console in Snapmaker Luban.
2, Enter command “M502”&“Enter” and then “M500”&“Enter” in order.
3, Then, please re-calibrate the heated.
4, Try to print again.

My only difference was I had to go into jog mode and ask it to home, then it kept the Z axis instead of resetting it.

However now it won’t calibrate, it pushes down to hard at point 5 denting it more and then stops trying to auto calibrate. I manually calibrated it and tried to start a print and it tore through the print bed, thank god i have a spare i bought cause the one that came with it is trashed

1 Like

I also received the same email from the support team.

For some reason I also found that my homing position keeps going out of sync.

There’s a possibility that my heat bed and linear modules are also damaged due to the calibration issue.

Thank you for sharing your experiences folks. I received my A350 yesterday and have completed basic assembly. I will try to watch this forum for a couple of days before I attempt homing for the first time.

I have a question for the group - would there be a safe way for me to test homing/calibration without risking the print bed? If I tried homing to a piece of cardboard or something would that seem like a reasonable replacement?

@mechan8, the savest way would be, disassamble the print head, while you see what happens.

Thank you @xchrisd - I ran the calibration routine a few times just holding the print head in place with one hand. It was tricky to hold the head very still so it pushed on the build plate sometimes, but never very hard. With this test I felt safe to mount the head with the screws, and when I did that I found the machine calibrated successfully (no damage).

My A350 has always homed at the top. Is this not correct?

Hi @DroneOn, I believe homing at the top is correct. For 3D printing the system also calibrates to the build plate at 9 points. Does this answer your question?

Thanks for the verification that it is supposed to come at the top. I do not use auto or quick calibration, only manual because my bed is not flat enough/9 points aren’t enough to level the adequately for consistent first layers.

1 Like