Snapmaker 2.0 New Linear Module XY Issue & Solution

I was so excited to receive the new linear modules today. Unfortunately after installing them according to the inclosed document, I encountered a issue for X and Y modules.

The following video show the Snapmaker attempting a calibration.

*** WARNING - The sound the snapmaker is doing in that video will hurt your soul! ***

After digging into the situation I realized that any X and Y steps increments were way bigger than expected. When I was requesting 10 mm of movement, the toll head moved by 25 mm following for X and Y axis; Z was moving as expected. There X steps and Y steps were off while Z steps setting was okay.

Inspection of M92 command showed that X, Y and Z were set at 400.00. By simply setting X steps and Y steps to 160.00 fixed the issue.


The linear module for X and Y require their respective X and Y steps to be readjusted:

  1. Retrieve the existing Xsteps and Ysteps from the firmware:

  2. Set the new Xsteps and Ysteps 40% of the current one
    M92 X<new_X_value> Y<new_Y_value>

  3. Save the new values

Note: I have only tried that with the 3D printer tool head, I assume the same calibration will have to be done on the other toolheads.

Sounds like you have the linear modules mixed up and installed wrong or have not updated the firmware.
They’re no longer all interchangeable. The z axis have different lead than the X & Y. The z are the same lead as the old, 8mm but the new x/y are 20mm.

Old modules can not be used at same time as new ones.


No. Installations are correct and it is the last firmware I double-checked.

Latest firmware

Both Z are the Lead 8mm

X and both Y are the Lead 20 mm

No mix and match with the old ones.

This happens when M92 is used - there’s a patch on Github, hasn’t been published yet. The workaround now is M502 to reset all settings, then M500 to save, then power cycle the machine.

1 Like

Had the same problem after installing new modules. Thank you for the temp solution. It worked for me.

Did you notice any play in the y-axis after resolving this issue. I experienced the same horrible event after installing the new linear modules. I have a test STL that seems to exhibit a line mid-way up but only if there is play in the y-axis.
SmallTest.stl (3.8 KB)

If I print three in various orientations, the one with the arrow, has a line running along the wall about half-way up similar to the attached photo.