Running a G-code file

hey guys, im trying to print this calibration file on my printer but its just a straight generated G-Code file. My printer says it cant copy the file onto itself to even start the print. thje file is from

anyone know what could possibly be wrong? has anyone been able to print a straight gcode file?

What method are you trying to send it to the machine? Via Luban or USB drive?

I have tried both ways with the same error.

I wonder if the Artisan has some form of check built in or something. Maybe try copying the header from a different file? I don’t have an Artisan to test myself. You could also try running it via USB serial with Octoprint.

Stupid question: Did you try to remove the parentheses from the file name?

Yeah I tried renaming the file and I tried putting different file types instead of .gcode also

I’ve found on my own laser generated file that Luban adds certain NaN values which the parser fails to interpret.

Check if you have anything similar to my issue.