Problem generating gcode for laser cutting

Recently got my Snapmaker 2.0 A350 and so far am very impressed. 3D printing test and laser engraving went well out of the gates. I’m having a problem generating gcode to do some laser cutting. I have tried opening a file as a .svg and a .jpg (indicating it’s vector). In the ‘editor’ mode, the design shows up properly (screen print 1). However, the ‘processor’ mode shows screen print 2. I was able to get the ‘processor’ mode to show the correct design at one point but when I went to cut out the design, the preview on the touch screen showed the design shown in screen print 2. I am using CorelDraw to generate the design and then exporting it. Should I export to a different format - one that’s more compatable with Luban?

I’m sorry if this is something discussed somewhere else in the forum. I am new to not only Snapmaker but to working with forums.Thanks in advance for any help you can give me.

Hi, welcome to the forums!

Some people have had luck opening the file in inkscape and resaving. Haven’t found anything conclusive as to why that works.

Also, post the file.

The gcode file? Long (37.7 KB)

The SVG too, please.

Initial look at that gcode file - there’s something seriously wrong lol. Feed speeds are incredibly slow, multipass with each Z lowering 0mm…just overall craziness. Gcode wouldn’t even preview for me.

Here’s the toolpaths, lmao:

There’s coordinates in this file like G1 X5679.59 Y-2405.64

Without the source image there’s not much else I can offer.

Long Side
I tried generating the files with the lines both as ‘hairline’ and as .05mm. It didn’t seem to make a difference.

I thought I uploaded the .svg file but it isn’t showing Long Side in my previous reply.

Tried again to upload the file. I don’t know what I’m doing wrong.

Could you upload it to Google drive or anywhere and post a link to it?

And lol, no worries, we’ll get it sorted out.

If you have any tips on getting paper to lay flat on the work table I’ll trade info with you. That’s what I’m currently fighting.

OK, this works better :slight_smile: Sorry. I’m new to forums and I don’t find them easy to use.
Re paper laying flat on the work table, I used to buy time at a laser cutting studio. They had small thin metal disks to hold down material. They were thinner than the distance between the laser head and the bed so as long as they weren’t in the path being engraved or cut, they worked fine.
Thanks for being patient with me.

Long Side.svg

To clarify, they were large ‘washers’.

That makes sense, that’s a good idea, thanks.

I just realized my work table isn’t even close to flat…wow.

As far as your file - I think you might be limited by being a new user. The forum software they use here has gradually expanding permissions as you’re on the forums longer. From here it explains basic users cannot upload attachments, which I think must be what it’s trying to upload as. So we’re going to have to find another way to get the file on here.

Do you have a Google Drive account, or dropbox, or anything you can put the file in and post a public link to it?

It’s getting late here. I’ll look into it tomorrow. Thanks for the info on why the attachment didn’t work.

Hopefully this will work:

Got it!

Immediately, I can see the same issue with Luban 3.9.0:

However, when I zoom out I see this:

I opened the file in Illustrator, and without changing anything hit save, and now this is the Process view:

I saved it with the default of SVG 1.1. You might double check how you’re saving it, and if CorelDraw gives you any options, play with different one. I compared the structure of the two files (yours, and my re-save) and there are significant differences. I’m wondering if CorelDraw saved it in a non-standard way.

Here’s my resave:
Long Side resave

It’s a step in the right direction - you can see the the travel moves and erroneous cuts between the different path segments. For instance, this is just one path:

There’s also some compound paths, like this:

Also at the corners the paths don’t meet:

The laser path generator will not see these as closed shapes, so you’ll want to snap the endpoints together and restructure these to be closed paths like this. Fixed on the left, you can see how the shape looks better now:

And in Luban you can see the closed shape has fewer travels and erroneous cuts:

Hope this helps, let me know if you have more questions.

Success! - well, almost. I opened my CorelDraw file with Inkscape and saved it as a .svg file. I was then able to open it in Luban and process it. I need to adjust the settings some because it didn’t cut all the way through but at least I’m making progress again.
Thanks for all of your help.

1 Like

One more quick question. Is the maximum size for the laser function 125 mm x 125 mm - even for the A350?

I assume whatever travel you can get out of the axis is what the machine can do - I’ve used at least a 200mm wide image, haven’t tested the full width and length in 1 go.