G-Code generation error for bed level test file


#1

I’m having trouble generating then uploading g-code within SnapMakerjs software. When attempting to print this bed level test file:

After I generate the G-code the image in the cube disappears. I click on “Load G-code to workspace” and get this error:

I’m not using a skirt or raft that setting is set to NONE.

The workspace should print to 125 x 125 mm correct? So why am I having problems generating this g-code and loading it to the workspace to print?

Thanks for your help!


#2

I can’t help with that particular issue, but I was able to level test using a single 100mm x 100mm x 0.1mm test using Snapmaker3D. I haven’t really played with SnapmakerJS yet. I didn’t try scaling it up to 120mm x 120mm. I was able to generate the GCode in Cura, but I didn’t print it.

For level testing, I found a 0.1mm thick print to be more useful. I saw one corner was noticeably thin compared to the other corners, even though the calibration paper it felt the same to me. A single 0.05mm step was enough to fix that issue. That small of a difference might be obscured in a 0.2mm thick print.

I printed https://www.thingiverse.com/thing:2125379 . I wanted the full square, not just the outer rim. I was having problems with prints that would adhere to the bed, then get pulled off on future passes. I did abort plenty of tests after it printed the inner and outer walls though. It turns out that I had the head too close to the bed, and PLA was squishing out sideways, pushing previous passes up off the bed.

I was surprised at how much I had to modify the calibration to get a consistently thick 0.1mm print that didn’t get pushed off the bed. I re-checked the calibration paper afterward, and all 4 corners have a different amount of force required to move the paper. One corner is so loose that I can easily move the paper in all four directions, and the opposite corner requires a firm grip on the paper to pull it out. That was done after the print, so the bed was warm (but cooling off).


#3

Thanks for the reply. I tried it in the “stable” software but for some reason that software doesn’t show on my laptop, the snapmaker software window opens but the buttons within don’t show. They are there but invisible. I unistalled, reinstalled like 5 times. Cleaned out my PC disc space, nothing worked so I tried the snapmakerjs which as you can see from the pics, at least shows up on my PC, but I can’t get the G-Code to populate.

Even when I scale it down I have the same issue.

I’ll try the file you shared to see if that works next.


#4

I tried multiple stl files now and I get this error with everything I try to generate G-code for using SnapMakerJS software, someone PLEASE HELP! @Rainie, can you help?


#5

Hi, could you please send me the STL file that causes this problem?
And did you try to use the latest version of Snapmakerjs?


#6

Hi Jade, it’s the test STL file from the SnapMaker Getting Started 3D printing post found here: [Official] Ready to MAKE for 3D printing

To my knowledge I’m running the latest version for SnapMakerjs, as you can see from my screen shots I’m running version 2.4.0. Thanks for any help you can send my way!


#7

Thank you. I know what’s wrong with it now. The height of the model is 0.2mm. However, the default initial layer height is 0.3mm and the layer height is 0.2mm when you choose Fast Print mode. So it is unable to generate the G-code file for this model.
To generate G-code file for it, you need to customize the initial layer height as well as the layer height to a value smaller or equal to 0.2mm.
Hope it helps.


#8

I even looked at that :man_facepalming: . I made the mistake of assuming that the Fast Print parameters are the same in SnapmakerJS and Snapmaker3D.


#9

Awesome! Thank you @Jade!! I was able to do my first print! Now on my second print the filament isn’t sticking to the bed. The brim sticks beautifully but when the actual object starts to print it doesn’t stick to the bed. I know that’s for a different section of the forum. I’ll look for that now and see if I can find other similar posts to help me out. Thanks!


#10

Hi, hope you enjoy a wonderful Christmas!
Did you fix the problem of prints not sticking to the bed? If not, you can read this article to learn all effective ways to solve this problem. :slight_smile:
https://snapmaker.zendesk.com/hc/en-us/articles/360013696613-What-should-I-do-if-the-first-layer-does-not-stick-to-the-heated-bed-