Printing Parameters are gone

Opened Luban, wanted to slice a model and got blank windows were the working parameters shold be.Downloaded and Installed the software again, still no printing parameters. what’s going on here? does anybody have the same problems?
Best, Christian

I had the same problem with my Macbook Mojave and Luban.
I rebuilt Mojave and reset Luban to 3.8.0.
Has worked now with 3.11.0

Thanks! Luban works well on my iMac, so i’ll have to change the configuration on my laptop. I’ll move on to cura as soon I’ve figured out how to set the profiles correctly…
Sadly, Luban isn’t ready complex models at the moment.

I’m having the same problem. What did you do to resolve this?

To be earnest, I just downloaded the most recent version of luban for Mac from the Snapmaker page and installed it in my other computer. It’s a 2009 iMac 27“.
I suppose it’s got to do with the version of the operating system running on the iMac, because that’s the only significant difference between the two machines.
I had problems with the installation, repeatedly getting „not able to install because resource is occupied“ messages, I didn’t get anytime before… I’ll try the software on another old Mac mini I will use in my Workshop, because the notebook is obviously useless at the moment.

It’s got to have to do with some very recent software packet or update I ran on the MacBook, because I have been working with luban a few weeks before.
I didn’t use the slicer, because I was doing some laser engraving and cutting till Friday, so I didn’t know that it had problems.

If I can figure out a work around, I’ll let you know.

Some other with the same problem rebuild Mojave, freshly installed an older luban and updated that version to do the trick, but I cannot afford the time at the moment, because we’re facing a complete lockdown in Germany starting on Wednesday and need the MacBook for work until I’ll face some quality time with my two boys at home… stay safe:-)

At one point I had to just manually do a search for luban (turn on include system folders) and delete all the folders and preference files I could find in system and library.
Then do a fresh install.


Thanks!! That’ll shorten the process a lot;-)

I had the same issue on Win10, after opening luban no printing and material options.

I renamed C:\Users[YourUsername]\AppData\Roaming\snapmaker-luban folder and restarted snapmaker the folder was recreated and printing and material options showing.

While trying to fix it, I uninstalled luban then the re installation was stopping with installation aborted error.

I deleted folders and file with luban in them from the temp directory

To tell the developers, I’d recommend that you raise an issue on GitHub here: